summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-01-16 02:39:49 +0000
committerJeremy Allison <jra@samba.org>2003-01-16 02:39:49 +0000
commit7dd7d3a96a9f23f1a7474625957fe3452222809a (patch)
tree29283638a123a35fd12766a528c5b04b7005714d /source3/configure.in
parenta84f1e7535b64dcfb1f274097cf947d0ad6fd1ec (diff)
downloadsamba-7dd7d3a96a9f23f1a7474625957fe3452222809a.tar.gz
samba-7dd7d3a96a9f23f1a7474625957fe3452222809a.tar.bz2
samba-7dd7d3a96a9f23f1a7474625957fe3452222809a.zip
Fist part of fixes to make us compile with Heimdal. Don't explicitly
detect for now, I still have vague hopes of hiding the differences between MIT and Heimdal with a compatibility layer.... Jeremy. (This used to be commit 54d83de8a23937f1d8179a7e2596df3c50785618)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 77ca2f0848..650cfe58a4 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2032,12 +2032,15 @@ fi
# now check for gssapi headers. This is also done here to allow for
# different kerberos include paths
- AC_CHECK_HEADERS(gssapi/gssapi_generic.h gssapi/gssapi.h)
+ AC_CHECK_HEADERS(gssapi.h gssapi/gssapi_generic.h gssapi/gssapi.h)
##################################################################
# we might need the k5crypto and com_err libraries on some systems
AC_CHECK_LIB(com_err, _et_list, [LIBS="$LIBS -lcom_err"])
AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
+ # Heimdal checks.
+ AC_CHECK_LIB(crypto, des_set_key, [LIBS="$LIBS -lcrypto"])
+ AC_CHECK_LIB(asn1, copy_Authenticator, [LIBS="$LIBS -lasn1 -lroken"])
########################################################
# now see if we can find the krb5 libs in standard paths
@@ -2049,6 +2052,9 @@ fi
# now see if we can find the gssapi libs in standard paths
AC_CHECK_LIB(gssapi_krb5, gss_display_status, [LIBS="$LIBS -lgssapi_krb5";
AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
+ # Heimdal checks.
+ AC_CHECK_LIB(gssapi, gss_display_status, [LIBS="$LIBS -lgssapi";
+ AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
fi
########################################################