summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2011-01-27 12:58:22 +0100
committerVolker Lendecke <vl@samba.org>2011-02-01 15:11:06 +0100
commit80acca1ebf8bd8d0350d63277e3143416372fb83 (patch)
tree715013c338e29d5566a86f3cf2ee4b36d5f72cca /source3/configure.in
parentf9af242886ac014baa3247bfdc1fe8be6cb8366e (diff)
downloadsamba-80acca1ebf8bd8d0350d63277e3143416372fb83.tar.gz
samba-80acca1ebf8bd8d0350d63277e3143416372fb83.tar.bz2
samba-80acca1ebf8bd8d0350d63277e3143416372fb83.zip
s3: Add support for AF_NETLINK addr notifications
Via an AF_NETLINK socket, the Linux kernel can inform us when IP addresses are added or dropped. This will first be used in winbind, it was triggered by clustering with ctdb. When winbind is connected to a domain controller and ctdb decides to move away the IP address that winbind used locally for the connection to the DC, the next request will run into a timeout. winbind sends out its request, but the response will never arrive: The IP is gone. It will also be interesting for more reliable online/offline detection, but this is something for future winbind refactoring.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cfaf99ba7b..b15bcf6e13 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5547,6 +5547,15 @@ else
fi
#################################################
+# check for rtnetlink
+
+AC_CHECK_HEADERS([linux/netlink.h],
+ AC_CHECK_HEADERS([linux/rtnetlink.h],[],[],
+ [#include <bits/sockaddr.h>
+ #include <linux/netlink.h>]),
+ [],[#include <bits/sockaddr.h>])
+
+#################################################
# check for ACL support
AC_MSG_CHECKING(whether to support ACLs)