summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorSteven Danneman <steven.danneman@isilon.com>2008-12-02 20:15:34 -0800
committerSteven Danneman <steven.danneman@isilon.com>2008-12-02 20:35:45 -0800
commit85b8cccab072bab263061654b677bc84826646c9 (patch)
treec7fce47ac46b22558b58d888d5d19a604d48387d /source3/configure.in
parent239f815e30a4e5f64112a8da6401614eb3218eb5 (diff)
downloadsamba-85b8cccab072bab263061654b677bc84826646c9.tar.gz
samba-85b8cccab072bab263061654b677bc84826646c9.tar.bz2
samba-85b8cccab072bab263061654b677bc84826646c9.zip
Add support for OneFS ACLs
Add to the OneFS VFS module, support for NTFS ACLs through the calls: SMB_VFS_FGET_NT_ACL() SMB_VFS_GET_NT_ACL() SMB_VFS_FSET_NT_ACL() Also create several new onefs specific smb.conf parameters in onefs.h
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f596ec5211..40e78e89d9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1052,6 +1052,8 @@ if test x"$samba_cv_HAVE_GPFS" = x"yes"; then
fi
LIBS="$save_LIBS"
+#############################################
+# check if building on Isilon OneFS
printf "%s" "checking for Isilon OneFS... "
save_LIBS="$LIBS"
LIBS="$LIBS -lisi_version"
@@ -1063,7 +1065,9 @@ echo $samba_cv_HAVE_ONEFS
if test x"$samba_cv_HAVE_ONEFS" = x"yes"; then
AC_DEFINE(HAVE_ONEFS,1,[Whether building on Isilon OneFS])
default_shared_modules="$default_shared_modules vfs_onefs"
+ ONEFS_LIBS="-lisi_acl"
fi
+AC_SUBST(ONEFS_LIBS)
LIBS="$save_LIBS"
# Note that all the libunwind symbols in the API are defined to internal