summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2002-10-01 05:54:40 +0000
committerJeremy Allison <jra@samba.org>2002-10-01 05:54:40 +0000
commit88e481ec13505f7e870a2172db3d4edf5ce47caf (patch)
tree53182ad8b674dbe40d08527dd59379fff89d1ab5 /source3/configure.in
parent88fad685d4c0e123ab0f85d8b081ae770569218e (diff)
downloadsamba-88e481ec13505f7e870a2172db3d4edf5ce47caf.tar.gz
samba-88e481ec13505f7e870a2172db3d4edf5ce47caf.tar.bz2
samba-88e481ec13505f7e870a2172db3d4edf5ce47caf.zip
Fix Solaris sendfile detection. Add small fixes to sendfile code.
Jeremy. (This used to be commit 7ba5636897ea57669c62d22bb399bcfe5e3a9907)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cd9c8ecbaf..01743d7d2f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2716,12 +2716,14 @@ samba_cv_HAVE_ACL_GET_PERM_NP=yes,samba_cv_HAVE_ACL_GET_PERM_NP=no)])
#################################################
# check for sendfile support
-AC_MSG_CHECKING(whether to support sendfile)
+AC_MSG_CHECKING(whether to check for support sendfile)
AC_ARG_WITH(sendfile-support,
-[ --with-sendfile-support Include sendfile support (default=no)],
+[ --with-sendfile-support Check for sendfile support (default=no)],
[ case "$withval" in
yes)
+ AC_MSG_RESULT(yes);
+
case "$host_os" in
*linux*)
AC_CACHE_CHECK([for linux sendfile64 support],samba_cv_HAVE_SENDFILE64,[
@@ -2867,6 +2869,7 @@ samba_cv_HAVE_SENDFILE=yes,samba_cv_HAVE_SENDFILE=no)])
size_t xferred;
struct sendfilevec vec[2];
ssize_t nwritten;
+ int tofd;
sfvcnt = 2;
@@ -2899,6 +2902,7 @@ samba_cv_HAVE_SENDFILEV64=yes,samba_cv_HAVE_SENDFILEV64=no)])
size_t xferred;
struct sendfilevec vec[2];
ssize_t nwritten;
+ int tofd;
sfvcnt = 2;