summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2012-11-21 16:32:38 +1100
committerAndreas Schneider <asn@samba.org>2012-11-22 10:21:16 +0100
commit8a2ef49dea36b103a87cf2aa63417737dd754ce6 (patch)
tree97e5fd48481171e45542383215be1921fbcef3bc /source3/configure.in
parentef195a18aac1f2b1ebfd34741d2242f659896549 (diff)
downloadsamba-8a2ef49dea36b103a87cf2aa63417737dd754ce6.tar.gz
samba-8a2ef49dea36b103a87cf2aa63417737dd754ce6.tar.bz2
samba-8a2ef49dea36b103a87cf2aa63417737dd754ce6.zip
build: Be consistent with the name of smbtorture binaries
This ensures that in both build systems, smbtorture3 is the source3 binary, and smbtoture is our main smbtorture binary, built with waf. Also included in this is the removal of bin/ndrdump4 as a special case. This removes the last cases of binaries with different names in each build system. Andrew Bartlett Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in22
1 files changed, 11 insertions, 11 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 179d12d120..cd80571474 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -203,13 +203,13 @@ AC_ARG_WITH(profiling-data,
)
dnl Checks for programs.
-AC_ARG_ENABLE(smbtorture4,
- [AS_HELP_STRING([--enable-smbtorture4], [Enable building smbtorture4 (default=auto)])])
+AC_ARG_ENABLE(smbtorture,
+ [AS_HELP_STRING([--enable-smbtorture], [Enable building smbtorture (default=auto)])])
-if test x$enable_smbtorture4 != xno; then
- smbtorture4_possible=yes
+if test x$enable_smbtorture != xno; then
+ smbtorture_possible=yes
else
- smbtorture4_possible=no
+ smbtorture_possible=no
fi
AC_PROG_INSTALL
@@ -220,11 +220,11 @@ AC_SAMBA_GNU_MAKE([true], [true])
# Check for perl
m4_include(../m4/check_perl.m4)
-AC_SAMBA_PERL([true], [smbtorture4_possible=no])
+AC_SAMBA_PERL([true], [smbtorture_possible=no])
# Check for python
m4_include(../m4/check_python.m4)
-AC_SAMBA_PYTHON_DEVEL([true], [smbtorture4_possible=no])
+AC_SAMBA_PYTHON_DEVEL([true], [smbtorture_possible=no])
AC_CHECK_TOOL(AR, ar)
@@ -1710,7 +1710,7 @@ if test x"$BLDSHARED" != x"true"; then
SHLD="shared-libraries-disabled"
PICFLAG="${PIE_CFLAGS}"
SHLIBEXT="shared_libraries_disabled"
- smbtorture4_possible=no
+ smbtorture_possible=no
fi
AC_MSG_CHECKING([used PICFLAG])
@@ -6519,9 +6519,9 @@ fi
m4_include(../lib/zlib/zlib.m4)
-if test x$smbtorture4_possible = xyes; then
- SMBTORTURE4="bin/smbtorture4"
- AC_SUBST(SMBTORTURE4)
+if test x$smbtorture_possible = xyes; then
+ SMBTORTURE="bin/smbtorture"
+ AC_SUBST(SMBTORTURE)
fi
AC_SUBST(ZLIB_LIBS)