summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2004-11-05 00:57:29 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:53:09 -0500
commit8ea9237d82857ecd6111c37d1ce6b9122ff50f44 (patch)
tree863bc9cf4eaebfa0d11d0eca0b60840e9aeda126 /source3/configure.in
parente73d23d1badbf76b6f53007fd48105b4e9f39eb1 (diff)
downloadsamba-8ea9237d82857ecd6111c37d1ce6b9122ff50f44.tar.gz
samba-8ea9237d82857ecd6111c37d1ce6b9122ff50f44.tar.bz2
samba-8ea9237d82857ecd6111c37d1ce6b9122ff50f44.zip
r3538: Fix the build with the latest Heimdal code.
Jeremy. (This used to be commit 34275bae787762646f02ea1dec19d7b3a9a733a3)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d32d684358..170b3c0d1c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2795,6 +2795,18 @@ if test x"$with_ads_support" != x"no"; then
LIBS="$KRB5_LIBS $LIBS"
+ AC_CACHE_CHECK([for krb5_encrypt_block type],
+ samba_cv_HAVE_KRB5_ENCRYPT_BLOCK,[
+ AC_TRY_COMPILE([#include <krb5.h>],
+ [krb5_encrypt_block block;],
+ samba_cv_HAVE_KRB5_ENCRYPT_BLOCK=yes,
+ samba_cv_HAVE_KRB5_ENCRYPT_BLOCK=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_ENCRYPT_BLOCK" = x"yes"; then
+ AC_DEFINE(HAVE_KRB5_ENCRYPT_BLOCK,1,
+ [Whether the type krb5_encrypt_block exists])
+ fi
+
AC_CACHE_CHECK([for addrtype in krb5_address],
samba_cv_HAVE_ADDRTYPE_IN_KRB5_ADDRESS,[
AC_TRY_COMPILE([#include <krb5.h>],