summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2008-10-27 23:23:15 +0100
committerJelmer Vernooij <jelmer@samba.org>2008-10-27 23:23:15 +0100
commit9de5172a20dff6f8e1fd0a94cde52977479e0c62 (patch)
tree3e506e1c7a62751c1f9a334d401fcf717c3fa308 /source3/configure.in
parentb881d2ee78f685aea7ae8b67b3e0fb3c4f5205ed (diff)
downloadsamba-9de5172a20dff6f8e1fd0a94cde52977479e0c62.tar.gz
samba-9de5172a20dff6f8e1fd0a94cde52977479e0c62.tar.bz2
samba-9de5172a20dff6f8e1fd0a94cde52977479e0c62.zip
Remove duplicate check for volatile, move all utime-checks to
libreplace.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 2 insertions, 10 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cd849349c0..292ae070d6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -314,14 +314,6 @@ fi
fi
fi
-dnl Check if the C compiler understands volatile (it should, being ANSI).
-AC_CACHE_CHECK([that the C compiler understands volatile],samba_cv_volatile, [
- AC_TRY_COMPILE([#include <sys/types.h>],[volatile int i = 0],
- samba_cv_volatile=yes,samba_cv_volatile=no)])
-if test x"$samba_cv_volatile" = x"yes"; then
- AC_DEFINE(HAVE_VOLATILE, 1, [Whether the C compiler understands volatile])
-fi
-
############################################
# check if the compiler can handle negative enum values
# and don't truncate the values to INT_MAX
@@ -661,7 +653,7 @@ AUTH_LIBS="${AUTH_LIBS} ${CRYPT_LIBS}"
AC_CHECK_HEADERS(aio.h sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h rpc/nettype.h)
-AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h memory.h alloca.h)
+AC_CHECK_HEADERS(unistd.h grp.h sys/id.h memory.h alloca.h)
AC_CHECK_HEADERS(limits.h float.h pthread.h)
AC_CHECK_HEADERS(rpc/rpc.h rpcsvc/nis.h rpcsvc/ypclnt.h)
AC_CHECK_HEADERS(sys/param.h ctype.h sys/wait.h sys/resource.h sys/ioctl.h sys/ipc.h sys/prctl.h)
@@ -1035,7 +1027,7 @@ fi
AC_CHECK_FUNCS(waitpid getcwd strdup strndup strnlen strerror chown fchown lchown chmod fchmod chroot link mknod mknod64)
AC_CHECK_FUNCS(strtol strtoll strtoul strtoull strtouq __strtoull)
-AC_CHECK_FUNCS(fstat strchr utime utimes chflags)
+AC_CHECK_FUNCS(fstat strchr chflags)
AC_CHECK_FUNCS(getrlimit fsync fdatasync memset strlcpy strlcat setpgid)
AC_CHECK_FUNCS(memmove setsid glob strpbrk pipe crypt16 getauthuid)
AC_CHECK_FUNCS(strftime sigprocmask sigblock sigaction sigset innetgr setnetgrent getnetgrent endnetgrent)