summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorPaul Green <paulg@samba.org>2004-04-13 12:28:38 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:51:13 -0500
commita60f81d1e09fb5effff6a4452327adac63766b74 (patch)
treef1e865093166cecc1fce5bcef5a881844b95aa65 /source3/configure.in
parentf4b35be4dd4c5f40c64056cf84af17f334efa68d (diff)
downloadsamba-a60f81d1e09fb5effff6a4452327adac63766b74.tar.gz
samba-a60f81d1e09fb5effff6a4452327adac63766b74.tar.bz2
samba-a60f81d1e09fb5effff6a4452327adac63766b74.zip
r192: Fix configure.in to only use $BLDSHARED to select whether to build static or shared libraries.
(This used to be commit 35d7435caec55765b39508889d77583c4ec4807c)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3a6269145d..0367b5f8d0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -4195,7 +4195,7 @@ if test x"$HAVE_WINBIND" = x"yes"; then
EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/wbinfo\$(EXEEXT)"
EXTRA_SBIN_PROGS="$EXTRA_SBIN_PROGS bin/winbindd\$(EXEEXT)"
- if test x"$BLDSHARED" = x"true"; then
+ if test $BLDSHARED = true; then
SHLIB_PROGS="$SHLIB_PROGS $WINBIND_NSS $WINBIND_WINS_NSS"
if test x"$with_pam" = x"yes"; then
@@ -4287,10 +4287,10 @@ done
for i in `echo $default_shared_modules | sed -e's/,/ /g'`
do
- dnl Fall back to static if dlopen() is not available
+ dnl Fall back to static if we cannot build shared libraries
eval MODULE_DEFAULT_$i=STATIC
- if test x"$ac_cv_func_dlopen" = xyes; then
+ if test $BLDSHARED = true; then
eval MODULE_DEFAULT_$i=SHARED
fi
done