summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2005-09-08 01:05:16 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:03:33 -0500
commitac01fda2b97b416467866ea9303a22de778f02e6 (patch)
treed5d388bfaa7701828ce6d608b6e5d7a132cda53a /source3/configure.in
parent378ebea94609aaf004317b1a9b42304a8718714b (diff)
downloadsamba-ac01fda2b97b416467866ea9303a22de778f02e6.tar.gz
samba-ac01fda2b97b416467866ea9303a22de778f02e6.tar.bz2
samba-ac01fda2b97b416467866ea9303a22de778f02e6.zip
r10068: Use prctl(PR_SET_DUMPABLE) to make sure we can always leave a good
looking corpse on Linux. (This used to be commit 7c97a1bcc34892d7bf697b9421ba8caf4061d9b5)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5ebb3c1e14..fd439e423f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -733,7 +733,7 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(aio.h arpa/inet.h sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h rpc/nettype.h)
AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h limits.h memory.h alloca.h)
AC_CHECK_HEADERS(rpc/rpc.h rpcsvc/nis.h rpcsvc/ypclnt.h)
-AC_CHECK_HEADERS(sys/param.h ctype.h sys/wait.h sys/resource.h sys/ioctl.h sys/ipc.h)
+AC_CHECK_HEADERS(sys/param.h ctype.h sys/wait.h sys/resource.h sys/ioctl.h sys/ipc.h sys/prctl.h)
AC_CHECK_HEADERS(sys/mman.h sys/filio.h sys/priv.h sys/shm.h string.h strings.h stdlib.h sys/socket.h)
AC_CHECK_HEADERS(sys/un.h)
AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h termio.h)
@@ -1160,6 +1160,15 @@ AC_CHECK_FUNCS(__sys_llseek llseek _llseek __llseek readdir64 _readdir64 __readd
AC_CHECK_FUNCS(pread _pread __pread pread64 _pread64 __pread64)
AC_CHECK_FUNCS(pwrite _pwrite __pwrite pwrite64 _pwrite64 __pwrite64)
AC_CHECK_FUNCS(open64 _open64 __open64 creat64)
+AC_CHECK_FUNCS(prctl)
+
+AC_TRY_COMPILE([
+#ifdef HAVE_SYS_PRCTL_H
+#include <sys/prctl.h>
+#endif
+],
+[int i; i = prtcl(0); ],
+AC_DEFINE(HAVE_PRCTL, 1, [Whether prctl is available]),[])
#
#