summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2002-12-04 19:47:01 +0000
committerJeremy Allison <jra@samba.org>2002-12-04 19:47:01 +0000
commitb0504a952650fb31bdc71d53204c8ada9cd74816 (patch)
treefd438e089e996420e8f0d3eedfd10f2c1685597d /source3/configure.in
parent8a2f73215a41f2ab65632e7c70351ece076b1589 (diff)
downloadsamba-b0504a952650fb31bdc71d53204c8ada9cd74816.tar.gz
samba-b0504a952650fb31bdc71d53204c8ada9cd74816.tar.bz2
samba-b0504a952650fb31bdc71d53204c8ada9cd74816.zip
Make sure we have a default st_blocksize.
Jeremy. (This used to be commit 904f6dfb7a00be560e931efeb1c05c98296eceb2)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in27
1 files changed, 15 insertions, 12 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f38732cc54..3cb5835fc3 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -873,7 +873,7 @@ case "$host_os" in
PICFLAG="-fPIC"
SONAMEFLAG="-Wl,-soname="
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
- ;;
+ ;;
*solaris*) AC_DEFINE(SUNOS5,1,[Whether the host os is solaris])
BLDSHARED="true"
LDSHFLAGS="-G"
@@ -892,28 +892,28 @@ case "$host_os" in
PICSUFFIX="po.o"
fi
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
- ;;
+ ;;
*sunos*) AC_DEFINE(SUNOS4,1,[Whether the host os is sunos4])
BLDSHARED="true"
LDSHFLAGS="-G"
SONAMEFLAG="-Wl,-h,"
PICFLAG="-KPIC" # Is this correct for SunOS
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
- ;;
+ ;;
*freebsd*) BLDSHARED="true"
LDSHFLAGS="-shared"
DYNEXP="-Wl,--export-dynamic"
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC -DPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
- ;;
+ ;;
*openbsd*) BLDSHARED="true"
LDSHFLAGS="-shared"
DYNEXP="-Wl,-Bdynamic"
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
- ;;
+ ;;
*irix*) AC_DEFINE(IRIX,1,[Whether the host os is irix])
case "$host_os" in
*irix6*) AC_DEFINE(IRIX6,1,[Whether the host os is irix6])
@@ -930,7 +930,7 @@ case "$host_os" in
PICFLAG="-KPIC"
fi
AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
- ;;
+ ;;
*aix*) AC_DEFINE(AIX,1,[Whether the host os is aix])
BLDSHARED="true"
LDSHFLAGS="-Wl,-bexpall,-bM:SRE,-bnoentry"
@@ -942,7 +942,7 @@ case "$host_os" in
fi
AC_DEFINE(STAT_ST_BLOCKSIZE,DEV_BSIZE,[The size of a block])
- ;;
+ ;;
*hpux*) AC_DEFINE(HPUX,1,[Whether the host os is HPUX])
SHLIBEXT="sl"
# Use special PIC flags for the native HP-UX compiler.
@@ -955,7 +955,7 @@ case "$host_os" in
fi
DYNEXP="-Wl,-E"
AC_DEFINE(STAT_ST_BLOCKSIZE,8192,[The size of a block])
- ;;
+ ;;
*qnx*) AC_DEFINE(QNX,1,[Whether the host os is qnx])
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
@@ -965,7 +965,7 @@ case "$host_os" in
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
- ;;
+ ;;
*sco*) AC_DEFINE(SCO,1,[Whether the host os is sco unix])
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
@@ -975,7 +975,7 @@ case "$host_os" in
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-KPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
- ;;
+ ;;
*next2*) AC_DEFINE(NEXT2,1,[Whether the host os is NeXT v2])
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
@@ -993,7 +993,7 @@ case "$host_os" in
*mips-sni-sysv4*) AC_DEFINE(RELIANTUNIX,1,[Whether the host os is reliantunix]);;
esac
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
- ;;
+ ;;
*sysv5*) AC_DEFINE(SYSV,1,[Whether this is a system V system])
if [ test "$GCC" != yes ]; then
@@ -1001,7 +1001,10 @@ case "$host_os" in
fi
LDSHFLAGS="-G"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
- ;;
+ ;;
+ *)
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ ;;
esac
AC_SUBST(DYNEXP)
AC_MSG_RESULT($BLDSHARED)