summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-10-05 12:17:01 +0000
committerAndrew Tridgell <tridge@samba.org>1998-10-05 12:17:01 +0000
commitbfaff8ed1a3899c9aef7eaa2421d3d6467343ea1 (patch)
treeb8613065fc41cf94769d1950f30cd9756855048f /source3/configure.in
parentf151bf0694cd41bab2ed8a4ff260ff84f714ec5c (diff)
downloadsamba-bfaff8ed1a3899c9aef7eaa2421d3d6467343ea1.tar.gz
samba-bfaff8ed1a3899c9aef7eaa2421d3d6467343ea1.tar.bz2
samba-bfaff8ed1a3899c9aef7eaa2421d3d6467343ea1.zip
got smbwrapper working on IRIX 6.4. Things got a bit tricky,
especially as the headers get the syscall numbers wrong! (This used to be commit a5405f1ab069a3123a819311a87ca84f2c5f0fea)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a16ed13f78..ddacea3215 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -8,8 +8,15 @@ AC_PROG_INSTALL
AC_SUBST(SHELL)
AC_SUBST(MPROGS)
AC_SUBST(LDSHFLAGS)
+AC_SUBST(HOST_OS)
+AC_SUBST(WRAP32)
+AC_SUBST(PICFLAG)
AC_PROG_AWK
+
+PICFLAG="-fpic"
+HOST_OS="$host_os"
+
AC_CANONICAL_SYSTEM
case "$host_os" in
*linux*) AC_DEFINE(LINUX)
@@ -18,7 +25,10 @@ case "$host_os" in
LDSHFLAGS="-G";;
*sunos*) AC_DEFINE(SUNOS4);;
*irix*) AC_DEFINE(IRIX)
- LDSHFLAGS="-shared";;
+ LDSHFLAGS="-shared"
+ WRAP32=smbwrapper/smbwrapper.32.so
+ PICFLAG="-KPIC"
+ ;;
*aix*) AC_DEFINE(AIX);;
*hpux*) AC_DEFINE(HPUX);;
*qnx*) AC_DEFINE(QNX);;