summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-11-15 21:43:57 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-11-15 21:43:57 +0000
commitc64d762997c80bd9ad2d47d1799cf9ec870d455a (patch)
tree6839d179517104a114f726a8ee4d7a299c3534f6 /source3/configure.in
parent392e2b2a0aab5e0e86d831b462b174abe8d089cb (diff)
downloadsamba-c64d762997c80bd9ad2d47d1799cf9ec870d455a.tar.gz
samba-c64d762997c80bd9ad2d47d1799cf9ec870d455a.tar.bz2
samba-c64d762997c80bd9ad2d47d1799cf9ec870d455a.zip
Updates from HEAD:
- const for PACKS() in lanman.c - change auth to 'account before password' - add help to net rpc {vampire,samsync} - configure updates for sun workshop cc - become_root() around pdb_ calls in auth_util for guest login. Andrew Bartlett (This used to be commit 43e90eb6e331d478013a9c038292f245edc51bd0)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 167f977522..7a251fde83 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1003,9 +1003,16 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
[ac_cv_shlib_works],[
ac_cv_shlib_works=no
# try building a trivial shared library
- $CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
- $CC $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
- ac_cv_shlib_works=yes
+ if test "$PICSUFFIX" = "po"; then
+ $CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
+ $CC $CPPFLAGS $CFLAGS `eval echo $LDSHFLAGS` -o shlib.so shlib.po &&
+ ac_cv_shlib_works=yes
+ else
+ $CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.$PICSUFFIX ${srcdir-.}/tests/shlib.c &&
+ mv shlib.$PICSUFFIX shlib.po &&
+ $CC $CPPFLAGS $CFLAGS `eval echo $LDSHFLAGS` -o shlib.so shlib.po &&
+ ac_cv_shlib_works=yes
+ fi
rm -f shlib.so shlib.po
])
if test $ac_cv_shlib_works = no; then