summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Warfield <mhw@samba.org>1998-09-28 19:18:21 +0000
committerMichael Warfield <mhw@samba.org>1998-09-28 19:18:21 +0000
commitcdaa53e3ef7e9bbb7dedaa82d54f730085b9250c (patch)
tree8d1770c17112a594229cfc699c157e96d5039515 /source3/configure.in
parenta97a4b8b99d6b3a57b01b0097e8a3583dd60f816 (diff)
downloadsamba-cdaa53e3ef7e9bbb7dedaa82d54f730085b9250c.tar.gz
samba-cdaa53e3ef7e9bbb7dedaa82d54f730085b9250c.tar.bz2
samba-cdaa53e3ef7e9bbb7dedaa82d54f730085b9250c.zip
Two changes in this ball...
1) Changes to smbmnt.c, smbmount.c, and smbumount.c allow them to compile on both RedHat 4.x (libc 4.x) systems and RedHat 5.x (glibc 2) systems. 2) Changes to Makefile.in and configure.in (and subsequently configure) are to configure for smbmount, smbumount, and smbmnt to compile. This adds a "--with(out)-smbmount" option to configure. Sanity checking is not present yet. You can specify this if you are not on linux, it just won't compile. (This used to be commit 8a4730f61923577b0bd9e09ef1a00538f7dfb0de)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f6483c6d30..3c8b2712e9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6,6 +6,7 @@ dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
AC_SUBST(SHELL)
+AC_SUBST(MPROGS)
AC_PROG_AWK
AC_CANONICAL_SYSTEM
@@ -525,6 +526,27 @@ AC_ARG_WITH(automount,
)
#################################################
+# check for smbmount support
+AC_MSG_CHECKING(whether to use SMBMOUNT)
+AC_ARG_WITH(smbmount,
+[ --with-smbmount Include SMBMOUNT (Linux only) support
+ --without-smbmount Don't include SMBMOUNT support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_SMBMOUNT)
+ MPROGS="bin/smbmount bin/smbmnt bin/smbumount"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ MPROGS=
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+ MPROGS=
+)
+
+#################################################
# check for a LDAP password database
AC_MSG_CHECKING(whether to use LDAP password database)
AC_ARG_WITH(ldap,