summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2008-07-16 17:27:05 -0700
committerJeremy Allison <jra@samba.org>2008-07-16 17:27:05 -0700
commitcdabee2bb45f51f49a0c7148fe5b761d1c13658c (patch)
tree6037d5c80434aa5616dc5922160da9175c45870d /source3/configure.in
parente0f3ea2cbeb61cb02be85d2b315948985bac27a8 (diff)
downloadsamba-cdabee2bb45f51f49a0c7148fe5b761d1c13658c.tar.gz
samba-cdabee2bb45f51f49a0c7148fe5b761d1c13658c.tar.bz2
samba-cdabee2bb45f51f49a0c7148fe5b761d1c13658c.zip
This patchset comprises a number of cleanups for the cifs upcall
binary. The biggest change is that it renames it from cifs.spnego to cifs.upcall since the cifs.spnego name really isn't applicable anymore. It also fixes a segfault when the program is run without any args and adds a manpage. Comments and/or suggestions appreciated. This set should apply cleanly to the 3.3 test branch. Signed-off-by: Jeff Layton <jlayton@redhat.com> Jeremy. (This used to be commit c633f10d9e78327664e6bca51f66756bcf0505a6)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in32
1 files changed, 16 insertions, 16 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 2ae5e35295..cb0e37e4a2 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -109,9 +109,9 @@ AC_SUBST(EXTRA_BIN_PROGS)
AC_SUBST(CIFSMOUNT_PROGS)
AC_SUBST(INSTALL_CIFSMOUNT)
AC_SUBST(UNINSTALL_CIFSMOUNT)
-AC_SUBST(CIFSSPNEGO_PROGS)
-AC_SUBST(INSTALL_CIFSSPNEGO)
-AC_SUBST(UNINSTALL_CIFSSPNEGO)
+AC_SUBST(CIFSUPCALL_PROGS)
+AC_SUBST(INSTALL_CIFSUPCALL)
+AC_SUBST(UNINSTALL_CIFSUPCALL)
AC_SUBST(EXTRA_SBIN_PROGS)
AC_SUBST(EXTRA_ALL_TARGETS)
AC_SUBST(CONFIG_LIBS)
@@ -4035,14 +4035,14 @@ AC_ARG_WITH(cifsmount,
)
#################################################
-# check for cifs.spnego support
+# check for cifs.upcall support
AC_CHECK_HEADERS([keyutils.h], [HAVE_KEYUTILS_H=1], [HAVE_KEYUTILS_H=0])
-CIFSSPNEGO_PROGS=""
-INSTALL_CIFSSPNEGO=""
-UNINSTALL_CIFSSPNEGO=""
-AC_MSG_CHECKING(whether to build cifs.spnego)
-AC_ARG_WITH(cifsspnego,
-[AS_HELP_STRING([--with-cifsspnego], [Include cifs.spnego (Linux only) support (default=no)])],
+CIFSUPCALL_PROGS=""
+INSTALL_CIFSUPCALL=""
+UNINSTALL_CIFSUPCALL=""
+AC_MSG_CHECKING(whether to build cifs.upcall)
+AC_ARG_WITH(cifsupcall,
+[AS_HELP_STRING([--with-cifsupcall], [Include cifs.upcall (Linux only) support (default=no)])],
[ case "$withval" in
no)
AC_MSG_RESULT(no)
@@ -4051,15 +4051,15 @@ AC_ARG_WITH(cifsspnego,
case "$host_os" in
*linux*)
if test x"$use_ads" != x"yes"; then
- AC_MSG_ERROR(ADS support should be enabled for building cifs.spnego)
+ AC_MSG_ERROR(ADS support should be enabled for building cifs.upcall)
elif test x"$HAVE_KEYUTILS_H" != "x1"; then
- AC_MSG_ERROR(keyutils package is required for cifs.spnego)
+ AC_MSG_ERROR(keyutils package is required for cifs.upcall)
else
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_CIFSSPNEGO,1,[whether to build cifs.spnego])
- CIFSSPNEGO_PROGS="bin/cifs.spnego"
- INSTALL_CIFSSPNEGO="installcifsspnego"
- UNINSTALL_CIFSSPNEGO="uninstallcifsspnego"
+ AC_DEFINE(WITH_CIFSUPCALL,1,[whether to build cifs.upcall])
+ CIFSUPCALL_PROGS="bin/cifs.upcall"
+ INSTALL_CIFSUPCALL="installcifsupcall"
+ UNINSTALL_CIFSUPCALL="uninstallcifsupcall"
fi
;;
*)