summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2002-12-04 03:12:09 +0000
committerJeremy Allison <jra@samba.org>2002-12-04 03:12:09 +0000
commitce4628c199f8e8ac84aa7f2afe2de1d9d23e6fab (patch)
treea6508c65d5fc7c26e73b95bc0b217412c69b147b /source3/configure.in
parent9e962452d879edd6811ece18665a8601c70a27d5 (diff)
downloadsamba-ce4628c199f8e8ac84aa7f2afe2de1d9d23e6fab.tar.gz
samba-ce4628c199f8e8ac84aa7f2afe2de1d9d23e6fab.tar.bz2
samba-ce4628c199f8e8ac84aa7f2afe2de1d9d23e6fab.zip
Fix for 64 bit issues with oplocks and allocation size.
Jeremy. (This used to be commit 379e719e983fb71f94cd2b691f8b194c109496c3)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 10067c46a8..f38732cc54 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -898,6 +898,7 @@ case "$host_os" in
LDSHFLAGS="-G"
SONAMEFLAG="-Wl,-h,"
PICFLAG="-KPIC" # Is this correct for SunOS
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
*freebsd*) BLDSHARED="true"
LDSHFLAGS="-shared"
@@ -955,22 +956,32 @@ case "$host_os" in
DYNEXP="-Wl,-E"
AC_DEFINE(STAT_ST_BLOCKSIZE,8192,[The size of a block])
;;
- *qnx*) AC_DEFINE(QNX,1,[Whether the host os is qnx]);;
+ *qnx*) AC_DEFINE(QNX,1,[Whether the host os is qnx])
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ ;;
*osf*) AC_DEFINE(OSF1,1,[Whether the host os is osf1])
BLDSHARED="true"
LDSHFLAGS="-shared"
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-fPIC"
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
- *sco*) AC_DEFINE(SCO,1,[Whether the host os is sco unix]);;
+ *sco*) AC_DEFINE(SCO,1,[Whether the host os is sco unix])
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ ;;
*unixware*) AC_DEFINE(UNIXWARE,1,[Whether the host os is unixware])
BLDSHARED="true"
LDSHFLAGS="-shared"
SONAMEFLAG="-Wl,-soname,"
PICFLAG="-KPIC"
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
- *next2*) AC_DEFINE(NEXT2,1,[Whether the host os is NeXT v2]);;
- *dgux*) AC_CHECK_PROG( ROFF, groff, [groff -etpsR -Tascii -man]);;
+ *next2*) AC_DEFINE(NEXT2,1,[Whether the host os is NeXT v2])
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ ;;
+ *dgux*) AC_CHECK_PROG( ROFF, groff, [groff -etpsR -Tascii -man])
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
+ ;;
*sysv4*) AC_DEFINE(SYSV,1,[Whether this is a system V system])
case "$host" in
*-univel-*) if [ test "$GCC" != yes ]; then
@@ -981,6 +992,7 @@ case "$host_os" in
;;
*mips-sni-sysv4*) AC_DEFINE(RELIANTUNIX,1,[Whether the host os is reliantunix]);;
esac
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
*sysv5*) AC_DEFINE(SYSV,1,[Whether this is a system V system])
@@ -988,6 +1000,7 @@ case "$host_os" in
AC_DEFINE(HAVE_MEMSET,1,[Whether memset() is available])
fi
LDSHFLAGS="-G"
+ AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
esac
AC_SUBST(DYNEXP)