summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2009-04-23 17:23:13 +0200
committerVolker Lendecke <vl@samba.org>2009-05-01 12:30:58 +0200
commitdb2cc8c9f2ec6f98884b1eb7738148cecdf6fd45 (patch)
treeb87388c09704cc939ce56408936b6c86d31da31a /source3/configure.in
parentf3af298e5b1457ba8661fd0e3f5304ad3175f3ba (diff)
downloadsamba-db2cc8c9f2ec6f98884b1eb7738148cecdf6fd45.tar.gz
samba-db2cc8c9f2ec6f98884b1eb7738148cecdf6fd45.tar.bz2
samba-db2cc8c9f2ec6f98884b1eb7738148cecdf6fd45.zip
Add thread pool
Included if pthreads are found, can be disabled with --enable-pthreadpool=no Tim, Steven, I haven't yet seen comments from you. You have been asking for such a thing at SambaXP. Do you like this? :-)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4ed9e68d0d..fc925ee736 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5895,7 +5895,9 @@ else
fi
AC_CHECK_LIB(pthread, pthread_mutex_lock, [WINBIND_NSS_PTHREAD="-lpthread"
- AC_DEFINE(HAVE_PTHREAD, 1, [whether pthread exists])])
+ AC_DEFINE(HAVE_PTHREAD, 1, [whether pthread exists])
+ samba_cv_HAVE_PTHREAD=yes],
+ samba_cv_HAVE_PTHREAD=no)
AC_SUBST(WINBIND_NSS_PTHREAD)
AC_SUBST(WINBIND_NSS)
@@ -6051,6 +6053,17 @@ if test x"$enable_avahi" != x"no"; then
fi
#################################################
+# Check if user wants pthreadpool support
+
+AC_ARG_ENABLE(pthreadpool,
+[AS_HELP_STRING([--enable-pthreadpool], [Enable pthreads pool helper support (default=auto)])])
+
+if test x"$enable_pthreadpool" != x"no" -a x"$samba_cv_HAVE_PTHREAD" = x"yes"; then
+ AC_DEFINE(WITH_PTHREADPOOL, 1, [Whether to include pthreadpool helpers])
+ AC_SUBST(PTHREADPOOL_OBJ, "lib/pthreadpool.o")
+fi
+
+#################################################
# Check to see if we should use the included iniparser
AC_ARG_WITH(included-iniparser,