summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2006-12-28 18:09:32 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:16:45 -0500
commite1d4e31c440c08f8138ab16b3e0095aa371ca09e (patch)
tree73df5357a115ced17469a320dfb309d52ab7a423 /source3/configure.in
parent0b24e3d02147e68256bc8c64b3a9dcca9fda3a9b (diff)
downloadsamba-e1d4e31c440c08f8138ab16b3e0095aa371ca09e.tar.gz
samba-e1d4e31c440c08f8138ab16b3e0095aa371ca09e.tar.bz2
samba-e1d4e31c440c08f8138ab16b3e0095aa371ca09e.zip
r20386: remove unneeded dlopen related configure checks and includes
this is done by libreplace... this hopefully fixes the build on HPUX 11.00 metze (This used to be commit eed50e104794d855b204cfea52626f47b6fa3f52)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 2 insertions, 7 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f8f0c18831..a666b10f8c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -860,7 +860,7 @@ AC_CHECK_HEADERS(sys/mman.h sys/filio.h sys/priv.h sys/shm.h string.h strings.h
AC_CHECK_HEADERS(sys/un.h)
AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h termio.h)
AC_CHECK_HEADERS(sys/termio.h sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h sys/sockio.h)
-AC_CHECK_HEADERS(sys/sysmacros.h dlfcn.h)
+AC_CHECK_HEADERS(sys/sysmacros.h)
AC_CHECK_HEADERS(sys/syslog.h syslog.h)
AC_CHECK_HEADERS(langinfo.h locale.h)
AC_CHECK_HEADERS(xfs/libxfs.h)
@@ -978,11 +978,6 @@ if test x$enable_iprint != xno; then
fi
############################################
-# we need dlopen/dlclose/dlsym/dlerror for PAM, the password database plugins and the plugin loading code
-AC_SEARCH_LIBS(dlopen, [dl])
-# dlopen/dlclose/dlsym/dlerror will be checked again later and defines will be set then
-
-############################################
# check if the compiler can do immediate structures
AC_CACHE_CHECK([if the compiler will optimize out function calls],samba_cv_optimize_out_funcation_calls, [
AC_TRY_LINK([
@@ -1223,7 +1218,7 @@ if test x"$ac_cv_func_execl" = x"no"; then
EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/smbrun\$(EXEEXT)"
fi
-AC_CHECK_FUNCS(dlopen dlclose dlsym dlerror waitpid getcwd strdup strndup strnlen strerror chown fchown chmod fchmod chroot link mknod mknod64)
+AC_CHECK_FUNCS(waitpid getcwd strdup strndup strnlen strerror chown fchown chmod fchmod chroot link mknod mknod64)
AC_CHECK_FUNCS(strtol strtoll strtoul strtoull strtouq __strtoull)
AC_CHECK_FUNCS(fstat strchr utime utimes getrlimit fsync memset strlcpy strlcat setpgid)
AC_CHECK_FUNCS(memmove vsnprintf snprintf asprintf vasprintf setsid glob strpbrk pipe crypt16 getauthuid)