summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2008-09-16 07:54:49 +0200
committerJelmer Vernooij <jelmer@samba.org>2008-09-16 07:54:49 +0200
commitec1c854f2175823bd1ad39c2e272d1b3fab80bf1 (patch)
treebb2946e678ce5f5e761f11299abca0179d65913a /source3/configure.in
parent0016bc40918fb6de71c670b3dd93934690dcee4f (diff)
parent4dfa72423ef96b411e797eb1b5b4cb3ebd8e3d32 (diff)
downloadsamba-ec1c854f2175823bd1ad39c2e272d1b3fab80bf1.tar.gz
samba-ec1c854f2175823bd1ad39c2e272d1b3fab80bf1.tar.bz2
samba-ec1c854f2175823bd1ad39c2e272d1b3fab80bf1.zip
Merge branch 'master' of ssh://git.samba.org/data/git/samba into wmi
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 248c39ac4c..d9766e49d0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -876,6 +876,21 @@ if test x"$samba_cv_sig_atomic_t" = x"yes"; then
AC_DEFINE(HAVE_SIG_ATOMIC_T_TYPE,1,[Whether we have the atomic_t variable type])
fi
+AC_CACHE_CHECK([for struct sigevent type],samba_cv_struct_sigevent, [
+ AC_TRY_COMPILE([
+#include <sys/types.h>
+#if STDC_HEADERS
+#include <stdlib.h>
+#include <stddef.h>
+#endif
+#include <signal.h>],[struct sigevent s;],
+ samba_cv_struct_sigevent=yes,samba_cv_struct_sigevent=no)])
+if test x"$samba_cv_struct_sigevent" = x"yes"; then
+ AC_DEFINE(HAVE_STRUCT_SIGEVENT,1,[Whether we have the struct sigevent])
+ AC_CHECK_MEMBERS([struct sigevent.sigev_value.sival_ptr,struct sigevent.sigev_value.sigval_ptr], , ,
+ [#include <signal.h>])
+fi
+
AC_CACHE_CHECK([for struct timespec type],samba_cv_struct_timespec, [
AC_TRY_COMPILE([
#include <sys/types.h>