summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-05-17 12:42:39 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-05-17 12:42:39 +0000
commiteed5094264945ca8ccf47030375cc56808ae8ea3 (patch)
tree4a39aca15191b1a857e60f5a4b761fce29867688 /source3/configure.in
parenta64932dfc06af46d4a4eebd6fb537e229466b00b (diff)
downloadsamba-eed5094264945ca8ccf47030375cc56808ae8ea3.tar.gz
samba-eed5094264945ca8ccf47030375cc56808ae8ea3.tar.bz2
samba-eed5094264945ca8ccf47030375cc56808ae8ea3.zip
This removes --with-ssl from Samba.
This option was badly maintained, useless and confused our users and distirbutors. (its SSL, therfore it must be good...) No windows client uses this protocol without help from an SSL tunnel. I can't see any reason why setting up a unix-side SSL wrapper would be any more difficult than the > 10 config options this mess added to samba in any case. On the Samba client end, I think the LIBSMB_PROG hack should be sufficient to start stunnel on the unix side. We might extend this to take %i and %p (IP and port) if there is demand. Andrew Bartlett (This used to be commit b04561d3fd3ee732877790fb4193b20ad72a75f8)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in68
1 files changed, 0 insertions, 68 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 51722d6eb1..a6277bdeac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2192,74 +2192,6 @@ AC_ARG_WITH(nisplus-home,
)
#################################################
-# check for the secure socket layer
-AC_MSG_CHECKING(whether to use SSL)
-AC_ARG_WITH(ssl,
-[ --with-ssl Include SSL support (default=no)
- --with-sslinc=DIR Where the SSL includes are (defaults to /usr/local/ssl/include)
- --with-ssllib=DIR Where the SSL libraries are (defaults to /usr/local/ssl/lib)],
-[ case "$withval" in
- yes)
- AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_SSL)
- withval="/usr/local/ssl" # default
-
- if test "${with_sslinc+set}" = set; then
-
- withval="$with_sslinc"
- case "$withval" in
- yes|no)
- echo "configure: warning: --with-sslinc called without argument - will use default" 1>&w
- CFLAGS="-I/usr/local/ssl/include $CFLAGS"
- ;;
- * )
- CFLAGS="-I${withval} $CFLAGS"
- ;;
- esac
-
- else
-
- CFLAGS="-I/usr/local/ssl/include $CFLAGS"
-
- fi
-
- if test "${with_ssllib+set}" = set; then
-
- withval="$with_ssllib"
- case "$withval" in
- yes|no)
- echo "configure: warning: --with-ssllib called without argument - will use default" 1>&w
- LDFLAGS="-L/usr/local/ssl/lib $LDFLAGS"
- ;;
- * )
- LDFLAGS="-L${withval}/lib $LDFLAGS"
- ;;
- esac
-
- else
-
- LDFLAGS="-L/usr/local/ssl/lib $LDFLAGS"
-
- fi
-
- LIBS="-lssl -lcrypto $LIBS"
-
-# if test ! -d ${withval}; then
-# echo "configure: error: called with --with-ssl, but ssl base directory ${withval} does not exist or is not a directory. Aborting config" 1>&2
-# exit 1
-# fi
-
- CFLAGS="-DHAVE_CRYPT_DECL $CFLAGS" # Damn, SSLeay defines its own
-
- ;;
- *)
- AC_MSG_RESULT(no)
- ;;
- esac ],
- AC_MSG_RESULT(no)
-)
-
-#################################################
# check for syslog logging
AC_MSG_CHECKING(whether to use syslog logging)
AC_ARG_WITH(syslog,