summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2003-01-30 17:07:28 +0000
committerGerald Carter <jerry@samba.org>2003-01-30 17:07:28 +0000
commitf02f723ddea6c46338f55a912dce80c6a8b84d5b (patch)
tree4c7dfb0fc3ed9f352cbbbcbae649cd7fe0d976ef /source3/configure.in
parentcf292aead6bdcced9deac62c50b25e83779d9741 (diff)
downloadsamba-f02f723ddea6c46338f55a912dce80c6a8b84d5b.tar.gz
samba-f02f723ddea6c46338f55a912dce80c6a8b84d5b.tar.bz2
samba-f02f723ddea6c46338f55a912dce80c6a8b84d5b.zip
Straus VOS detection patches from Paul Green
(This used to be commit 29962f99f2972bd780366753abf4615c0e8fbda1)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 759690f60d..0336e581b3 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -322,6 +322,26 @@ case "$host_os" in
esac
;;
#
+# VOS may need to have POSIX support and System V compatibility enabled.
+#
+ *vos*)
+ case "$CPPFLAGS" in
+ *-D_POSIX_C_SOURCE*)
+ ;;
+ *)
+ CPPFLAGS="$CPPFLAGS -D_POSIX_C_SOURCE=199506L"
+ AC_DEFINE(_POSIX_C_SOURCE, 199506L, [Whether to enable POSIX support])
+ ;;
+ esac
+ case "$CPPFLAGS" in
+ *-D_SYSV*|*-D_SVID_SOURCE*)
+ ;;
+ *)
+ CPPFLAGS="$CPPFLAGS -D_SYSV"
+ AC_DEFINE(_SYSV, 1, [Whether to enable System V compatibility])
+ esac
+ ;;
+#
# Tests needed for SINIX large file support.
#
*sysv4*)
@@ -993,6 +1013,10 @@ case "$host_os" in
LDSHFLAGS="-G"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
+ *vos*) AC_DEFINE(STAT_ST_BLOCKSIZE,4096)
+ BLDSHARED="false"
+ LDSHFLAGS=""
+ ;;
*)
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;