summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorKai Blin <kai@samba.org>2010-06-20 09:36:19 +0200
committerKai Blin <kai@samba.org>2010-06-20 09:50:19 +0200
commitff32f691bba41afab45efe7e21a2c91bb2c157bb (patch)
treef11abfcb1be7e990176c34882a90aa75ef25e114 /source3/configure.in
parentfa3e50fee421a7fe407510627e0fdbcd5f4013c0 (diff)
downloadsamba-ff32f691bba41afab45efe7e21a2c91bb2c157bb.tar.gz
samba-ff32f691bba41afab45efe7e21a2c91bb2c157bb.tar.bz2
samba-ff32f691bba41afab45efe7e21a2c91bb2c157bb.zip
s3 configure: Check for (set|get|end)netgrent prototypes
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cda14f54fe..04ddc03792 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6418,7 +6418,30 @@ AC_SUBST(BUILD_INIPARSER)
AC_SUBST(INIPARSERLIBS)
AC_SUBST(FLAGS1)
-
+###################################################
+# Check for different/missing (set|get|end)netgrent prototypes
+CFLAGS_SAVE=$CFLAGS
+CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
+AC_CACHE_CHECK([for setnetgrent prototype],samba_cv_setnetgrent_prototype, [
+ AC_TRY_COMPILE([#include<netdb.h>],[setnetgrent("foo")],
+ samba_cv_setnetgrent_prototype=yes, samba_cv_setnetgrent_prototype=no)])
+if test x"$samba_cv_setnetgrent_prototype" = x"yes"; then
+ AC_DEFINE(HAVE_SETNETGRENT_PROTOTYPE, 1, [If setnetgrent prototype is defined])
+fi
+AC_CACHE_CHECK([for getnetgrent prototype],samba_cv_getnetgrent_prototype, [
+ AC_TRY_COMPILE([#include<netdb.h>],[char *dom, *user,*host; getnetgrent(&dom,&user,&host)],
+ samba_cv_getnetgrent_prototype=yes, samba_cv_getnetgrent_prototype=no)])
+if test x"$samba_cv_getnetgrent_prototype" = x"yes"; then
+ AC_DEFINE(HAVE_GETNETGRENT_PROTOTYPE, 1, [If getnetgrent prototype is defined])
+fi
+AC_CACHE_CHECK([for endnetgrent prototype],samba_cv_endnetgrent_prototype, [
+ AC_TRY_COMPILE([#include<netdb.h>],[endnetgrent()],
+ samba_cv_endnetgrent_prototype=yes, samba_cv_endnetgrent_prototype=no)])
+if test x"$samba_cv_endnetgrent_prototype" = x"yes"; then
+ AC_DEFINE(HAVE_ENDNETGRENT_PROTOTYPE, 1, [If endnetgrent prototype is defined])
+fi
+
+CFLAGS=$CFLAGS_SAVE
# Checks for the vfs_fileid module
# Start