summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAlexander Bokovoy <ab@samba.org>2013-02-06 12:22:12 +0200
committerAlexander Bokovoy <ab@samba.org>2013-02-06 13:32:53 +0100
commitff496ef29fe0eb8db929ba014abf5f8eeed86b33 (patch)
treebb507e108eb252784b846f84ff5e7036874d2566 /source3/configure.in
parente721e7132e7bb32850ff8b2af654b8f3ebf955fe (diff)
downloadsamba-ff496ef29fe0eb8db929ba014abf5f8eeed86b33.tar.gz
samba-ff496ef29fe0eb8db929ba014abf5f8eeed86b33.tar.bz2
samba-ff496ef29fe0eb8db929ba014abf5f8eeed86b33.zip
autoconf: rename pdb_ldap module to pdb_ldapsam
Reviewed-by: Andreas Schneider <asn@samba.org> Autobuild-User(master): Alexander Bokovoy <ab@samba.org> Autobuild-Date(master): Wed Feb 6 13:32:53 CET 2013 on sn-devel-104
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b17a37ec9e..031a33da20 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3276,7 +3276,7 @@ if test x"$with_ldap_support" != x"no"; then
if test x"$ac_cv_lib_ext_ldap_ldap_init" = x"yes"; then
AC_DEFINE(HAVE_LDAP,1,[Whether ldap is available])
CPPFLAGS="$CPPFLAGS -DLDAP_DEPRECATED"
- default_static_modules="$default_static_modules pdb_ldap idmap_ldap";
+ default_static_modules="$default_static_modules pdb_ldapsam idmap_ldap";
default_shared_modules="$default_shared_modules";
SMBLDAP="lib/smbldap.o"
with_ldap_support=yes
@@ -6348,13 +6348,18 @@ AC_ARG_WITH(shared-modules,
done
fi ])
+# additionally, support pdb_ldap -> pdb_ldapsam replacement
+if test x"$MODULE_pdb_ldap" != x ; then
+ MODULE_pdb_ldapsam="$MODULE_pdb_ldap"
+fi
+
if test x"$MODULE_DEFAULT_vfs_notify_fam" = xSTATIC -o \
x"$MODULE_vfs_notify_fam" = xSTATIC ; then
SMBD_FAM_LIBS="$SMB_FAM_LIBS"
AC_SUBST(SMBD_FAM_LIBS)
fi
-SMB_MODULE(pdb_ldap, passdb/pdb_ldap.o passdb/pdb_nds.o passdb/pdb_ipa.o passdb/pdb_ldap_util.o,
+SMB_MODULE(pdb_ldapsam, passdb/pdb_ldap.o passdb/pdb_nds.o passdb/pdb_ipa.o passdb/pdb_ldap_util.o,
"bin/ldapsam.$SHLIBEXT", PDB,
[ PASSDB_LIBS="$PASSDB_LIBS $LDAP_LIBS" ] )
SMB_MODULE(pdb_smbpasswd, passdb/pdb_smbpasswd.o, "bin/smbpasswd.$SHLIBEXT", PDB)