summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBjörn Jacke <bj@sernet.de>2013-02-19 15:30:34 +0100
committerBjoern Jacke <bj@sernet.de>2013-02-19 20:56:12 +0100
commitff8ba0628f6f13a5be1df94e5ac2e83008b7c69c (patch)
tree022eb3b526501225ce1a0fc65a89980dd789323c /source3/configure.in
parent432dde0223d884b7de1a9d3c0655304efbcf1f88 (diff)
downloadsamba-ff8ba0628f6f13a5be1df94e5ac2e83008b7c69c.tar.gz
samba-ff8ba0628f6f13a5be1df94e5ac2e83008b7c69c.tar.bz2
samba-ff8ba0628f6f13a5be1df94e5ac2e83008b7c69c.zip
build/autoconf: fix check for GNU ld version
we need to look for the version once in the stdout and once in the stderr output. Some version of ld output to stdout, some output to stderr. redirecting stderr to stdout messes the output up in our case, that's why we have to do two runs. See also bug #7825. Signed-off-by: Bjoern Jacke <bj@sernet.de> Reviewed-by: Stefan Metzmacher <metze@samba.org> Autobuild-User(master): Björn Jacke <bj@sernet.de> Autobuild-Date(master): Tue Feb 19 20:56:12 CET 2013 on sn-devel-104
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1b24ad6a04..594f4b9e14 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -227,7 +227,11 @@ dnl Certain versions of GNU ld the default is not to have the
dnl --allow-shlib-undefined flag defined. This causes a stackload of
dnl warnings when building modules.
if test "$ac_cv_prog_gnu_ld" = "yes"; then
- ac_cv_gnu_ld_version=`$CC -Wl,-v /dev/null 2>&1 < /dev/null | grep "GNU ld"`
+ ac_cv_gnu_ld_version=`$CC -Wl,-v /dev/null 2> /dev/null < /dev/null | grep "GNU ld"`
+ # we need to make a 2nd (separate!) check on the output of stderr, see bug #7825:
+ if test -z ${ac_cv_gnu_ld_version} ; then
+ ac_cv_gnu_ld_version=`$CC -Wl,-v /dev/null 2>&1 > /dev/null < /dev/null | grep "GNU ld"`
+ fi
AC_MSG_CHECKING(GNU ld release date)
changequote(,)dnl
ac_cv_gnu_ld_date=`echo $ac_cv_gnu_ld_version | sed -n 's,^.*\([2-9][0-9][0-9][0-9]\)[-]*\([01][0-9]\)[-]*\([0-3][0-9]\).*$,\1\2\3,p'`