summaryrefslogtreecommitdiff
path: root/source3/lib/replace/configure.ac
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2006-09-18 22:49:20 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:52:03 -0500
commit8f153c6128dd15fb132d8ddb1752e793bd6a5985 (patch)
tree0e2314019948ef0fdfcce1a15a63c0a4828e6bb7 /source3/lib/replace/configure.ac
parentf2e7b8d1449b9f8a7177a19842d25440950f733f (diff)
downloadsamba-8f153c6128dd15fb132d8ddb1752e793bd6a5985.tar.gz
samba-8f153c6128dd15fb132d8ddb1752e793bd6a5985.tar.bz2
samba-8f153c6128dd15fb132d8ddb1752e793bd6a5985.zip
r18644: bring in libreplace in lib/replace
metze (This used to be commit 596cbe73dd268742acf456fccd8a234376fb0c97)
Diffstat (limited to 'source3/lib/replace/configure.ac')
-rw-r--r--source3/lib/replace/configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/source3/lib/replace/configure.ac b/source3/lib/replace/configure.ac
new file mode 100644
index 0000000000..48fb7ce259
--- /dev/null
+++ b/source3/lib/replace/configure.ac
@@ -0,0 +1,22 @@
+AC_PREREQ(2.50)
+AC_INIT(replace.c)
+AC_CONFIG_SRCDIR([replace.c])
+AC_CONFIG_HEADER(config.h)
+
+AC_LIBREPLACE_ALL_CHECKS
+
+if test "$ac_cv_prog_gcc" = yes; then
+ CFLAGS="$CFLAGS -Wall"
+ CFLAGS="$CFLAGS -W"
+ CFLAGS="$CFLAGS -Wshadow"
+ CFLAGS="$CFLAGS -Wstrict-prototypes"
+ CFLAGS="$CFLAGS -Wpointer-arith"
+ CFLAGS="$CFLAGS -Wcast-qual"
+ CFLAGS="$CFLAGS -Wcast-align"
+ CFLAGS="$CFLAGS -Wwrite-strings"
+ CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
+ CFLAGS="$CFLAGS -Wformat=2"
+ CFLAGS="$CFLAGS -Wno-format-y2k"
+fi
+
+AC_OUTPUT(Makefile)