summaryrefslogtreecommitdiff
path: root/source3/python/setup.py
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2004-03-24 23:52:11 +0000
committerTim Potter <tpot@samba.org>2004-03-24 23:52:11 +0000
commit78502504451b9ea21a8f4035a3e7e9626a6b2108 (patch)
tree7c5df8b99c991bb1a4468a7b8241cb62db828abe /source3/python/setup.py
parentcc98a35689b114aed9bab705e54881e5439805e3 (diff)
downloadsamba-78502504451b9ea21a8f4035a3e7e9626a6b2108.tar.gz
samba-78502504451b9ea21a8f4035a3e7e9626a6b2108.tar.bz2
samba-78502504451b9ea21a8f4035a3e7e9626a6b2108.zip
Path for bugzilla #1152 from Timur Bakeyev. Allow python modules to
build despite libraries added to LDFLAGS instead of LDPATH. (This used to be commit 98a25dcda8e53e22b48930131ff394414056f6a1)
Diffstat (limited to 'source3/python/setup.py')
-rwxr-xr-xsource3/python/setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/source3/python/setup.py b/source3/python/setup.py
index a9f220f195..4a4f6ad3f8 100755
--- a/source3/python/setup.py
+++ b/source3/python/setup.py
@@ -57,6 +57,9 @@ for lib in string.split(samba_libs):
if lib[0:2] == "-L":
library_dirs.append(lib[2:])
continue
+ if lib[0:2] == "-W":
+ # Skip linker flags
+ continue
print "Unknown entry '%s' in $LIBS variable passed to setup.py" % lib
sys.exit(1)