summaryrefslogtreecommitdiff
path: root/source3/python/setup.py
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2002-12-05 23:05:28 +0000
committerTim Potter <tpot@samba.org>2002-12-05 23:05:28 +0000
commitf7f3d42acf00b0b4b99f37cbd320c9c2aed6858e (patch)
tree245b2242336091d93fad3de043e814d8cbdb827d /source3/python/setup.py
parent902caf48ef0730a17bbb858c3ff9c68b823e5907 (diff)
downloadsamba-f7f3d42acf00b0b4b99f37cbd320c9c2aed6858e.tar.gz
samba-f7f3d42acf00b0b4b99f37cbd320c9c2aed6858e.tar.bz2
samba-f7f3d42acf00b0b4b99f37cbd320c9c2aed6858e.zip
Merge from HEAD:
>FUNCTION_MACRO change broke the Python modules. > >Also fix up string pasting (I thought this should only be a warning?) (This used to be commit 5bd90f310aa6303a5c949b46591f9fcf82a175b8)
Diffstat (limited to 'source3/python/setup.py')
-rwxr-xr-xsource3/python/setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/source3/python/setup.py b/source3/python/setup.py
index bf62f3b877..09a81fd914 100755
--- a/source3/python/setup.py
+++ b/source3/python/setup.py
@@ -179,6 +179,7 @@ setup(
# tdbpack/unpack extensions. Does not actually link to any Samba
# code, although it implements a compatible data format.
Extension(name = "tdbpack",
- sources = [os.path.join(samba_srcdir, "python", "py_tdbpack.c")]),
+ sources = [os.path.join(samba_srcdir, "python", "py_tdbpack.c")],
+ extra_compile_args = ["-I include"])
],
)