summaryrefslogtreecommitdiff
path: root/source3/wscript
diff options
context:
space:
mode:
authorKai Blin <kai@samba.org>2010-06-20 09:49:34 +0200
committerKai Blin <kai@samba.org>2010-06-20 09:50:19 +0200
commita453b87d68f89c48e0d0545fe240801e4eac1686 (patch)
tree09a262e3173cb5dde722537b026bcfa0e1f2644a /source3/wscript
parentff32f691bba41afab45efe7e21a2c91bb2c157bb (diff)
downloadsamba-a453b87d68f89c48e0d0545fe240801e4eac1686.tar.gz
samba-a453b87d68f89c48e0d0545fe240801e4eac1686.tar.bz2
samba-a453b87d68f89c48e0d0545fe240801e4eac1686.zip
s3-waf: Change the (set|get|end)netgrent checks to match the configure.in checks
Diffstat (limited to 'source3/wscript')
-rw-r--r--source3/wscript21
1 files changed, 12 insertions, 9 deletions
diff --git a/source3/wscript b/source3/wscript
index 9bbedeae79..aec71afc5c 100644
--- a/source3/wscript
+++ b/source3/wscript
@@ -362,15 +362,18 @@ utimensat vsyslog _write __write __xstat
define='HAVE_DIRENT_D_OFF')
conf.CHECK_FUNCS('setnetgrent getnetgrent endnetgrent')
- conf.CHECK_C_PROTOTYPE('setnetgrent',
- 'extern int setnetgrent(const char* netgroup)',
- define='HAVE_SETNETGRENT_PROTOTYPE', headers='netdb.h')
- conf.CHECK_C_PROTOTYPE('getnetgrent',
- 'extern int getnetgrent(char **host, char **user, char **domain)',
- define='HAVE_GETNETGRENT_PROTOTYPE', headers='netdb.h')
- conf.CHECK_C_PROTOTYPE('endnetgrent',
- 'extern void endnetgrent(void)',
- define='HAVE_ENDNETGRENT_PROTOTYPE', headers='netdb.h')
+ conf.CHECK_CODE('setnetgrent("foo")', 'HAVE_SETNETGRENT_PROTOTYPE',
+ msg="Checking for setnetgrent prototype",
+ headers='netdb.h',
+ cflags="-Werror-implicit-function-declaration")
+ conf.CHECK_CODE('getnetgrent', 'HAVE_GETNETGRENT_PROTOTYPE',
+ msg="Checking for getnetgrent prototype",
+ headers='netdb.h',
+ cflags="-Werror-implicit-function-declaration")
+ conf.CHECK_CODE('endnetgrent', 'HAVE_ENDNETGRENT_PROTOTYPE',
+ msg="Checking for endnetgrent prototype",
+ headers='netdb.h',
+ cflags="-Werror-implicit-function-declaration")
#FIXME: Should just be set when krb5 and ldap requirements are fulfilled
if Options.options.with_ads: