summaryrefslogtreecommitdiff
path: root/source3/wscript
diff options
context:
space:
mode:
authorRichard Sharpe <realrichardsharpe@gmail.com>2013-02-08 19:56:56 -0800
committerAndrew Bartlett <abartlet@samba.org>2013-02-09 09:24:06 +0100
commitc932b139c8d1fc0b6a357623fe4011edabb45422 (patch)
treea29ede16055d74291ba592477a433dfaae913698 /source3/wscript
parent233b32b771188a6b9ee730a2a202023370e80746 (diff)
downloadsamba-c932b139c8d1fc0b6a357623fe4011edabb45422.tar.gz
samba-c932b139c8d1fc0b6a357623fe4011edabb45422.tar.bz2
samba-c932b139c8d1fc0b6a357623fe4011edabb45422.zip
Improve the configure tests for aio_suspend to get rid of warnings. Timur provided the wscript method, I added the configure.in correction.
Signed-off-by: Timur Bakeyev <timur@freebsd.org> Signed-off-by: Richard Sharpe <realrichardsharpe@gmail.com> Reviewed-by: Andrew Bartlett <abartlet@samba.org> Autobuild-User(master): Andrew Bartlett <abartlet@samba.org> Autobuild-Date(master): Sat Feb 9 09:24:06 CET 2013 on sn-devel-104
Diffstat (limited to 'source3/wscript')
-rw-r--r--source3/wscript2
1 files changed, 1 insertions, 1 deletions
diff --git a/source3/wscript b/source3/wscript
index 84abf76a3d..7a99dc1c55 100644
--- a/source3/wscript
+++ b/source3/wscript
@@ -471,7 +471,7 @@ return acl_get_perm_np(permset_d, perm);
conf.CHECK_CODE('struct aiocb a; return aio_return(&a);', 'HAVE_AIO_RETURN', msg='Checking for aio_return', headers='aio.h', lib='aio rt')
conf.CHECK_CODE('struct aiocb a; return aio_error(&a);', 'HAVE_AIO_ERROR', msg='Checking for aio_error', headers='aio.h', lib='aio rt')
conf.CHECK_CODE('struct aiocb a; return aio_cancel(1, &a);', 'HAVE_AIO_CANCEL', msg='Checking for aio_cancel', headers='aio.h', lib='aio rt')
- conf.CHECK_CODE('struct aiocb a; struct timespec t; return aio_suspend(&a, 1, &t);', 'HAVE_AIO_SUSPEND', msg='Checking for aio_suspend', headers='aio.h', lib='aio rt')
+ conf.CHECK_CODE('const struct aiocb * const a[1]; struct timespec t; return aio_suspend(&a, 1, &t);', 'HAVE_AIO_SUSPEND', msg='Checking for aio_suspend', headers='aio.h', lib='aio rt')
if not conf.CONFIG_SET('HAVE_AIO'):
conf.DEFINE('HAVE_NO_AIO', '1')
else: