summaryrefslogtreecommitdiff
path: root/source4/cluster/ctdb/configure.ac
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2007-07-10 08:06:51 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:59:20 -0500
commit6504900f1f52927adab3489b8d04b6644ceaee7d (patch)
tree893cadba231a529f320046429767cedf8b0eec30 /source4/cluster/ctdb/configure.ac
parentd4e2d157cbce5a1cdc75efb5ced75d9608a0f7df (diff)
downloadsamba-6504900f1f52927adab3489b8d04b6644ceaee7d.tar.gz
samba-6504900f1f52927adab3489b8d04b6644ceaee7d.tar.bz2
samba-6504900f1f52927adab3489b8d04b6644ceaee7d.zip
r23806: update Samba4 with the latest ctdb code.
This doesn't get the ctdb code fully working in Samba4, it just gets it building and not breaking non-clustered use of Samba. It will take a bit longer to update some of the calling ctdb_cluster.c code to make it work correctly in Samba4. Note also that Samba4 now only links to the client portion of ctdb. For the moment I am leaving the ctdbd as a separate daemon, which you install separately from http://ctdb.samba.org/. (This used to be commit b196077cbb55cbecad87065133c2d67198e31066)
Diffstat (limited to 'source4/cluster/ctdb/configure.ac')
-rw-r--r--source4/cluster/ctdb/configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/source4/cluster/ctdb/configure.ac b/source4/cluster/ctdb/configure.ac
index 784eef2190..86a70d157d 100644
--- a/source4/cluster/ctdb/configure.ac
+++ b/source4/cluster/ctdb/configure.ac
@@ -12,7 +12,7 @@ AC_DEFUN([SMB_LIBRARY_ENABLE], [echo -n ""])
AC_DEFUN([SMB_EXT_LIB], [echo -n ""])
AC_DEFUN([SMB_ENABLE], [echo -n ""])
AC_INIT(ctdb.h)
-AC_CONFIG_SRCDIR([tests/ctdb_test.c])
+AC_CONFIG_SRCDIR([server/ctdbd.c])
AC_LIBREPLACE_ALL_CHECKS
@@ -24,10 +24,25 @@ AC_CONFIG_HEADER(config.h)
EXTRA_OBJ=""
+m4_include(libpopt.m4)
m4_include(libtalloc.m4)
m4_include(libtdb.m4)
+m4_include(libevents.m4)
m4_include(ib/config.m4)
+AC_CHECK_HEADERS(sched.h)
+AC_CHECK_FUNCS(sched_setscheduler)
+
+AC_CACHE_CHECK([for sin_len in sock],ctdb_cv_HAVE_SOCK_SIN_LEN,[
+AC_TRY_COMPILE([#include <sys/types.h>
+#include <sys/socket.h>
+#include <netinet/in.h>],
+[struct sockaddr_in sock; sock.sin_len = sizeof(sock);],
+ctdb_cv_HAVE_SOCK_SIN_LEN=yes,ctdb_cv_HAVE_SOCK_SIN_LEN=no)])
+if test x"$ctdb_cv_HAVE_SOCK_SIN_LEN" = x"yes"; then
+ AC_DEFINE(HAVE_SOCK_SIN_LEN,1,[Whether the sockaddr_in struct has a sin_len property])
+fi
+
AC_SUBST(EXTRA_OBJ)
AC_OUTPUT(Makefile)