summaryrefslogtreecommitdiff
path: root/source4/configure.ac
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2007-09-11 17:27:25 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 15:06:27 -0500
commit2e5f023a69cda6f507a2a820c97b0f095ce44678 (patch)
tree38dd9bb80b39d9f26c4696dc56fee1561cbf6a54 /source4/configure.ac
parent08ff1a50f2adf1b68bda79c0ce09316f266d16e6 (diff)
downloadsamba-2e5f023a69cda6f507a2a820c97b0f095ce44678.tar.gz
samba-2e5f023a69cda6f507a2a820c97b0f095ce44678.tar.bz2
samba-2e5f023a69cda6f507a2a820c97b0f095ce44678.zip
r25093: Use system-provided ldb library if available. Note that this only means using the ldb library from the system - the custom command-line tools for Samba 4 will still be built even if they are already provided by the system.
(This used to be commit 8aab673df5200a4555777caf4ee58907cf6fe4cc)
Diffstat (limited to 'source4/configure.ac')
-rw-r--r--source4/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/source4/configure.ac b/source4/configure.ac
index bb326985f3..4305bf717d 100644
--- a/source4/configure.ac
+++ b/source4/configure.ac
@@ -43,6 +43,18 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBTDB, tdb >= 1.1.0,
]
)
+SMB_EXT_LIB_FROM_PKGCONFIG(LIBLDB, ldb >= 0.9.1,
+ [
+ SMB_INCLUDE_MK(lib/ldb/ldb_ildap/config.mk)
+ SMB_INCLUDE_MK(lib/ldb/tools/config.mk)
+ SMB_SUBSYSTEM(ldb_map, LIBLDB)
+ ],
+ [
+ m4_include(lib/ldb/libldb.m4)
+ SMB_INCLUDE_MK(lib/ldb/config.mk)
+ ]
+)
+
m4_include(lib/ldb/sqlite3.m4)
m4_include(lib/ldb/libldb.m4)
m4_include(lib/tls/config.m4)