summaryrefslogtreecommitdiff
path: root/source4/configure.ac
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2009-03-26 16:28:45 +0100
committerJelmer Vernooij <jelmer@samba.org>2009-03-26 16:28:45 +0100
commit494e471d747c1e858481fad16cb33574d3e7f985 (patch)
tree3a32106bbb266c11a59b835df27b3482d203dc77 /source4/configure.ac
parent50189e81d04edd313f707fc3bb7f18e46389e9e6 (diff)
downloadsamba-494e471d747c1e858481fad16cb33574d3e7f985.tar.gz
samba-494e471d747c1e858481fad16cb33574d3e7f985.tar.bz2
samba-494e471d747c1e858481fad16cb33574d3e7f985.zip
configure: Use m4 defines for minimum library versions rather than shell
variables, so the values rather than the variable names show up in configure output.
Diffstat (limited to 'source4/configure.ac')
-rw-r--r--source4/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/source4/configure.ac b/source4/configure.ac
index 065a3300ca..3c23f27d68 100644
--- a/source4/configure.ac
+++ b/source4/configure.ac
@@ -44,14 +44,14 @@ AC_CONFIG_FILES(librpc/dcerpc_atsvc.pc)
m4_include(min_versions.m4)
-SMB_INCLUDED_LIB_PKGCONFIG(LIBTALLOC, talloc >= $TALLOC_MIN_VERSION, [],
+SMB_INCLUDED_LIB_PKGCONFIG(LIBTALLOC, talloc >= TALLOC_MIN_VERSION, [],
[
m4_include(../lib/talloc/libtalloc.m4)
SMB_INCLUDE_MK(../lib/talloc/config.mk)
]
)
-SMB_INCLUDED_LIB_PKGCONFIG(LIBTDB, tdb >= $TDB_MIN_VERSION,
+SMB_INCLUDED_LIB_PKGCONFIG(LIBTDB, tdb >= TDB_MIN_VERSION,
[],
[
m4_include(../lib/tdb/libtdb.m4)
@@ -67,7 +67,7 @@ SMB_INCLUDED_LIB_PKGCONFIG(LIBTEVENT, tevent = TEVENT_REQUIRED_VERSION,
SMB_INCLUDE_MK(../lib/tevent/python.mk)
-SMB_INCLUDED_LIB_PKGCONFIG(LIBLDB, ldb = $LDB_REQUIRED_VERSION,
+SMB_INCLUDED_LIB_PKGCONFIG(LIBLDB, ldb = LDB_REQUIRED_VERSION,
[
SMB_INCLUDE_MK(lib/ldb/ldb_ildap/config.mk)
SMB_INCLUDE_MK(lib/ldb/tools/config.mk)