summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2004-05-22 01:29:42 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:53:52 -0500
commit39696f7804dcfa6a06710bbd8a25b9bfaf5113f9 (patch)
tree341203c003edf5e0eaaccf7fa82d1a6ad55f3d0f /source4/configure.in
parent32de5979810f472d25f8efcd10c15719d48b7393 (diff)
downloadsamba-39696f7804dcfa6a06710bbd8a25b9bfaf5113f9.tar.gz
samba-39696f7804dcfa6a06710bbd8a25b9bfaf5113f9.tar.bz2
samba-39696f7804dcfa6a06710bbd8a25b9bfaf5113f9.zip
r813: gcc has fixed its huge debug sizes with -g now, so drop the -gstabs,
allowing us to use a more standard debug format. If you want it even smaller than I recommend the -feliminate-dwarf2-dups option, if your version of gcc supports it. (This used to be commit a11340a971af24d9dcab720f92483b0dafa01142)
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/source4/configure.in b/source4/configure.in
index 43a8242788..15019b8e00 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -151,20 +151,20 @@ AC_ARG_ENABLE(debug,
[ --enable-debug Turn on compiler debugging information (default=no)],
[if eval "test x$enable_debug = xyes"; then
debug=yes
- CFLAGS="${CFLAGS} -gstabs"
+ CFLAGS="${CFLAGS} -g"
fi])
developer=no
AC_ARG_ENABLE(developer, [ --enable-developer Turn on developer warnings and debugging (default=no)],
[if eval "test x$enable_developer = xyes"; then
developer=yes
- CFLAGS="${CFLAGS} -gstabs -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -DDEBUG_PASSWORD -DDEVELOPER"
+ CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -DDEBUG_PASSWORD -DDEVELOPER"
fi])
AC_ARG_ENABLE(krb5developer, [ --enable-krb5developer Turn on developer warnings and debugging, except -Wstrict-prototypes (default=no)],
[if eval "test x$enable_krb5developer = xyes"; then
developer=yes
- CFLAGS="${CFLAGS} -gstabs -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -DDEBUG_PASSWORD -DDEVELOPER"
+ CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -DDEBUG_PASSWORD -DDEVELOPER"
fi])
experimental=no