summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-09-17 13:08:49 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:38:14 -0500
commit86acf90e4335f79cd34e400d687930d922332d8f (patch)
treedcaff9c775bba6808aac804d52044382db9840f1 /source4/configure.in
parent3198e58161387c7f4f8990c0355dbfa6beee3463 (diff)
downloadsamba-86acf90e4335f79cd34e400d687930d922332d8f.tar.gz
samba-86acf90e4335f79cd34e400d687930d922332d8f.tar.bz2
samba-86acf90e4335f79cd34e400d687930d922332d8f.zip
r10294: Generate Makefile directly rather then thru Makefile.in. Autoconf
substitution variables are now no longer used. This is one more step towards a (hopefully) perl-based configure (This used to be commit 6f9956a1dd870c0669c288b0fe72b7b1c8773dd0)
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/source4/configure.in b/source4/configure.in
index 752b7ad52f..6da3a52c33 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -84,6 +84,8 @@ dnl Remove -I/usr/include/? from CFLAGS and CPPFLAGS
CFLAGS_REMOVE_USR_INCLUDE(CFLAGS)
CFLAGS_REMOVE_USR_INCLUDE(CPPFLAGS)
+AC_SUBST(ac_default_prefix)
+
echo "configure: creating config.pm"
cat >config.pm<<CEOF
# config.pm - Autogenerate by configure. DO NOT EDIT!
@@ -112,4 +114,5 @@ $SMB_INFO_SUBSYSTEMS
$SMB_INFO_LIBRARIES
CEOF
-AC_OUTPUT(Makefile,,[$PERL -Ibuild build/smb_build/main.pl])
+AC_OUTPUT_COMMANDS([$PERL -Ibuild build/smb_build/main.pl],[PERL="$PERL"])
+AC_OUTPUT