summaryrefslogtreecommitdiff
path: root/source4/lib/events/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <idra@samba.org>2008-09-19 15:20:47 -0400
committerSimo Sorce <idra@samba.org>2008-09-19 18:08:12 -0400
commit474de0f2172ebe55e6cafb4ad7e81fe662eacadc (patch)
treec4012ed880a543e7e21ae53c36b6028b24878d46 /source4/lib/events/configure.ac
parent3235e25425dddb9ba6d0f8d7cfff94ea9d7c5bdd (diff)
downloadsamba-474de0f2172ebe55e6cafb4ad7e81fe662eacadc.tar.gz
samba-474de0f2172ebe55e6cafb4ad7e81fe662eacadc.tar.bz2
samba-474de0f2172ebe55e6cafb4ad7e81fe662eacadc.zip
Fix libevents standalone build
Make sure to build against libtalloc.a and not individual talloc objects, so that the library can be also built against libtalloc.so and use it as a shared library instead of statically compiling talloc. Also add shared-build target to the events library. Useful to build multiple standalone libraries that depend on each other without having to install them to the final install dir during the build.
Diffstat (limited to 'source4/lib/events/configure.ac')
-rw-r--r--source4/lib/events/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/source4/lib/events/configure.ac b/source4/lib/events/configure.ac
index fbd23b10e5..895f2a1daa 100644
--- a/source4/lib/events/configure.ac
+++ b/source4/lib/events/configure.ac
@@ -8,8 +8,6 @@ AC_CONFIG_SRCDIR([events.c])
AC_CONFIG_HEADER(config.h)
AC_LIBREPLACE_ALL_CHECKS
-m4_include(libtalloc.m4)
-
AC_LD_EXPORT_DYNAMIC
AC_LD_SONAMEFLAG
AC_LD_PICFLAG
@@ -17,6 +15,13 @@ AC_LD_SHLIBEXT
AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
AC_LIBREPLACE_RUNTIME_LIB_PATH_VAR
+
+m4_include(build_macros.m4)
+BUILD_WITH_SHARED_BUILD_DIR
+
+m4_include(pkg.m4)
+m4_include(libtalloc.m4)
+
m4_include(libevents.m4)
AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
AC_PATH_PROGS([PYTHON], [python2.6 python2.5 python2.4 python])