summaryrefslogtreecommitdiff
path: root/source4/lib/ldb/setup.py
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2007-11-27 23:28:23 +0100
committerStefan Metzmacher <metze@samba.org>2007-12-21 05:46:35 +0100
commit8463b9aff99d05a61048c8dc9dc249d544109bcd (patch)
tree702bbedbe483c005a9447dda9f11bf024bf9aa6e /source4/lib/ldb/setup.py
parent84945d9fae931314da4d0e09f69fad9681fc949a (diff)
downloadsamba-8463b9aff99d05a61048c8dc9dc249d544109bcd.tar.gz
samba-8463b9aff99d05a61048c8dc9dc249d544109bcd.tar.bz2
samba-8463b9aff99d05a61048c8dc9dc249d544109bcd.zip
r26177: Allow prebuilding swig wrapper, install ldb.py.
(This used to be commit e61160dce4bdfc8ade8494c91c8bbec13d0afe4b)
Diffstat (limited to 'source4/lib/ldb/setup.py')
-rwxr-xr-xsource4/lib/ldb/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/source4/lib/ldb/setup.py b/source4/lib/ldb/setup.py
index 77b54f434d..2ec6d7b055 100755
--- a/source4/lib/ldb/setup.py
+++ b/source4/lib/ldb/setup.py
@@ -9,7 +9,7 @@ setup(name="ldb",
author_email="ldb@samba.org",
license="LGPLv3",
keywords=["ldap","ldb","db","ldif"],
- ext_modules=[Extension('_ldb', ['ldb.i'], include_dirs=['include'],
- swig_opts=["-keyword"],
+ py_modules=["ldb"],
+ ext_modules=[Extension('_ldb', ['ldb_wrap.c'], include_dirs=['include'],
library_dirs=["lib"], libraries=['ldb','ldap'])],
)