summaryrefslogtreecommitdiff
path: root/source4/lib/replace/configure.ac
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2006-09-04 22:49:30 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:17:08 -0500
commita0202040e2b99117e6307e886fd08401330d20f8 (patch)
treedcd35ac75204926f847eea558dfa68752d9cd980 /source4/lib/replace/configure.ac
parent15352189d2ffa3441763563d92b8880aaf5ca450 (diff)
downloadsamba-a0202040e2b99117e6307e886fd08401330d20f8.tar.gz
samba-a0202040e2b99117e6307e886fd08401330d20f8.tar.bz2
samba-a0202040e2b99117e6307e886fd08401330d20f8.zip
r18051: - add gcc warning flags
- fix piles of warnings and ftruncate bug in libreplace testsuite (This used to be commit f5fc88f0c4c752a2773d5280ed4d94818e2d4744)
Diffstat (limited to 'source4/lib/replace/configure.ac')
-rw-r--r--source4/lib/replace/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/source4/lib/replace/configure.ac b/source4/lib/replace/configure.ac
index a05a9cbfe7..3d56c8d934 100644
--- a/source4/lib/replace/configure.ac
+++ b/source4/lib/replace/configure.ac
@@ -46,6 +46,12 @@ AC_INIT(dlfcn.c)
AC_CONFIG_SRCDIR([dlfcn.c])
AC_CONFIG_HEADER(replace_config.h)
AC_PROG_INSTALL
+AC_PROG_CC
+
+if test "$ac_cv_prog_gcc" = yes; then
+ CFLAGS="$CFLAGS -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings"
+fi
+
sinclude(config.m4)
sinclude(win32/config.m4)
sinclude(repdir/config.m4)