summaryrefslogtreecommitdiff
path: root/source4/lib/replace/configure.ac
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2006-09-05 11:21:16 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:17:11 -0500
commita57365a2e6f303572da011e490d05e1424c53934 (patch)
treebc1abd73c7858aa741ec5868e2cd49f37eae8abb /source4/lib/replace/configure.ac
parent3a70ec899a2d408bfc11cc21a3f470d22c080c15 (diff)
downloadsamba-a57365a2e6f303572da011e490d05e1424c53934.tar.gz
samba-a57365a2e6f303572da011e490d05e1424c53934.tar.bz2
samba-a57365a2e6f303572da011e490d05e1424c53934.zip
r18073: next step in grab libreplace plan - see IRC logs for very detailed
discussion wity metze and jelmer! (This used to be commit f18c913b6cf772c44dfaa8a3164cc78f6554e4a9)
Diffstat (limited to 'source4/lib/replace/configure.ac')
-rw-r--r--source4/lib/replace/configure.ac40
1 files changed, 0 insertions, 40 deletions
diff --git a/source4/lib/replace/configure.ac b/source4/lib/replace/configure.ac
index 3d56c8d934..2b5fbf1c18 100644
--- a/source4/lib/replace/configure.ac
+++ b/source4/lib/replace/configure.ac
@@ -1,46 +1,6 @@
AC_DEFUN([SMB_EXT_LIB], [echo -n ""])
AC_DEFUN([SMB_ENABLE], [echo -n ""])
-dnl see if a declaration exists for a function or variable
-dnl defines HAVE_function_DECL if it exists
-dnl AC_HAVE_DECL(var, includes)
-AC_DEFUN(AC_HAVE_DECL,
-[
- AC_CACHE_CHECK([for $1 declaration],ac_cv_have_$1_decl,[
- AC_TRY_COMPILE([$2],[int i = (int)$1],
- ac_cv_have_$1_decl=yes,ac_cv_have_$1_decl=no)])
- if test x"$ac_cv_have_$1_decl" = x"yes"; then
- AC_DEFINE([HAVE_]translit([$1], [a-z], [A-Z])[_DECL],1,[Whether $1() is available])
- fi
-])
-
-dnl AC_SEARCH_LIBS_EXT(FUNCTION, SEARCH-LIBS, EXT_LIBS,
-dnl [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND],
-dnl [OTHER-LIBRARIES])
-dnl --------------------------------------------------------
-dnl Search for a library defining FUNC, if it's not already available.
-AC_DEFUN([AC_SEARCH_LIBS_EXT],
-[AC_CACHE_CHECK([for library containing $1], [ac_cv_search_ext_$1],
-[
-ac_func_search_ext_save_LIBS=$LIBS
-ac_cv_search_ext_$1=no
-AC_LINK_IFELSE([AC_LANG_CALL([], [$1])],
- [ac_cv_search_ext_$1="none required"])
-if test "$ac_cv_search_ext_$1" = no; then
- for ac_lib in $2; do
- LIBS="-l$ac_lib $$3 $6 $ac_func_search_save_ext_LIBS"
- AC_LINK_IFELSE([AC_LANG_CALL([], [$1])],
- [ac_cv_search_ext_$1="-l$ac_lib"
-break])
- done
-fi
-LIBS=$ac_func_search_ext_save_LIBS])
-AS_IF([test "$ac_cv_search_ext_$1" != no],
- [test "$ac_cv_search_ext_$1" = "none required" || $3="$ac_cv_search_ext_$1 $$3"
- $4],
- [$5])dnl
-])
-
AC_PREREQ(2.50)
AC_INIT(dlfcn.c)
AC_CONFIG_SRCDIR([dlfcn.c])