summaryrefslogtreecommitdiff
path: root/source4/lib/tdb/configure.ac
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2008-02-12 00:35:11 +0100
committerJelmer Vernooij <jelmer@samba.org>2008-02-12 00:35:11 +0100
commit8244b4c0717b64b9effc27781f3d05fd816c5e5e (patch)
tree06ea41e2e8e719beb9c0227e8f44ab098e91ff6b /source4/lib/tdb/configure.ac
parentecb987c97c98d7374a0e703c56f2a71f8514ece8 (diff)
downloadsamba-8244b4c0717b64b9effc27781f3d05fd816c5e5e.tar.gz
samba-8244b4c0717b64b9effc27781f3d05fd816c5e5e.tar.bz2
samba-8244b4c0717b64b9effc27781f3d05fd816c5e5e.zip
Manually compile python files rather than using setup.py.
(This used to be commit 94dfeb5e89a641e2af3d7426d9d25c87952198d2)
Diffstat (limited to 'source4/lib/tdb/configure.ac')
-rw-r--r--source4/lib/tdb/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/source4/lib/tdb/configure.ac b/source4/lib/tdb/configure.ac
index 5747107f38..36d409ac11 100644
--- a/source4/lib/tdb/configure.ac
+++ b/source4/lib/tdb/configure.ac
@@ -11,15 +11,19 @@ AC_LD_PICFLAG
AC_LD_SHLIBEXT
AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
+AC_LIBREPLACE_RUNTIME_LIB_PATH_VAR
m4_include(libtdb.m4)
AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
PYTHON_BUILD_TARGET="build-python"
PYTHON_INSTALL_TARGET="install-python"
+PYTHON_CHECK_TARGET="check-python"
AC_SUBST(PYTHON_BUILD_TARGET)
AC_SUBST(PYTHON_INSTALL_TARGET)
+AC_SUBST(PYTHON_CHECK_TARGET)
if test -z "$PYTHON_CONFIG"; then
PYTHON_BUILD_TARGET=""
PYTHON_INSTALL_TARGET=""
+ PYTHON_CHECK_TARGET=""
fi
AC_OUTPUT(Makefile tdb.pc)