summaryrefslogtreecommitdiff
path: root/source4/lib/tdb/configure.ac
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2008-01-10 15:17:26 -0600
committerStefan Metzmacher <metze@samba.org>2008-01-10 09:21:11 -0600
commitdb5b0fcfb8d51bff5f7c62ce9c4b0daa71b919b1 (patch)
tree663d1c4ea01ed339ed91f428b44f70b72f066d9a /source4/lib/tdb/configure.ac
parentc781879e35b5ff29a21ab9ea4f0ca3b7c53280f7 (diff)
downloadsamba-db5b0fcfb8d51bff5f7c62ce9c4b0daa71b919b1.tar.gz
samba-db5b0fcfb8d51bff5f7c62ce9c4b0daa71b919b1.tar.bz2
samba-db5b0fcfb8d51bff5f7c62ce9c4b0daa71b919b1.zip
r26700: tdb: Build and install Python bindings when possible.
(This used to be commit 8d77ea379fef5ad4b2718bc8e0620304588c9239)
Diffstat (limited to 'source4/lib/tdb/configure.ac')
-rw-r--r--source4/lib/tdb/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/source4/lib/tdb/configure.ac b/source4/lib/tdb/configure.ac
index 3237d29fb0..5747107f38 100644
--- a/source4/lib/tdb/configure.ac
+++ b/source4/lib/tdb/configure.ac
@@ -12,4 +12,14 @@ AC_LD_SHLIBEXT
AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
m4_include(libtdb.m4)
+AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
+
+PYTHON_BUILD_TARGET="build-python"
+PYTHON_INSTALL_TARGET="install-python"
+AC_SUBST(PYTHON_BUILD_TARGET)
+AC_SUBST(PYTHON_INSTALL_TARGET)
+if test -z "$PYTHON_CONFIG"; then
+ PYTHON_BUILD_TARGET=""
+ PYTHON_INSTALL_TARGET=""
+fi
AC_OUTPUT(Makefile tdb.pc)