summaryrefslogtreecommitdiff
path: root/source4/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-08-21 23:30:17 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:34:17 -0500
commit59b13f9a1d684a632c2c73352f0ec08a63bc0913 (patch)
tree14b0a564e4db3377f7ad2fa1f9671f8e04405962 /source4/pidl/Makefile.PL
parentefc03df292aa84edb592c22191dbf86cdf8c32d0 (diff)
downloadsamba-59b13f9a1d684a632c2c73352f0ec08a63bc0913.tar.gz
samba-59b13f9a1d684a632c2c73352f0ec08a63bc0913.tar.bz2
samba-59b13f9a1d684a632c2c73352f0ec08a63bc0913.zip
r9460: - Move pidl to lib/. This fixes standalone installation of pidl.
- Update the README - Allow building the docs stand-alone (This used to be commit b56084ce251ab7a35dd1422f38de258e8e1e1477)
Diffstat (limited to 'source4/pidl/Makefile.PL')
-rwxr-xr-xsource4/pidl/Makefile.PL15
1 files changed, 12 insertions, 3 deletions
diff --git a/source4/pidl/Makefile.PL b/source4/pidl/Makefile.PL
index ae862bfdb5..efa94dc068 100755
--- a/source4/pidl/Makefile.PL
+++ b/source4/pidl/Makefile.PL
@@ -1,10 +1,9 @@
use ExtUtils::MakeMaker;
WriteMakefile(
'NAME' => 'Parse::Pidl',
- 'VERSION_FROM' => 'Parse/Pidl.pm',
+ 'VERSION_FROM' => 'lib/Parse/Pidl.pm',
'EXE_FILES' => [ 'pidl' ],
- 'PMLIBDIRS' => [ 'Parse' ],
- 'C' => [],
+ 'PMLIBDIRS' => [ 'lib' ],
'test' => { 'TESTS' => 'tests/*.pl' }
);
@@ -12,5 +11,15 @@ sub MY::postamble {
<<'EOT';
Parse/Pidl/IDL.pm :: idl.yp
yapp -s -m 'Parse::Pidl::IDL' -o 'Parse/Pidl/IDL.pm' idl.yp
+
+doc: pidl.1 pidl.1.html
+
+XSLTPROC=xsltproc
+
+%.1: %.1.xml
+ test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.html: %.xml
+ test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $<
EOT
}