summaryrefslogtreecommitdiff
path: root/source4/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-09-21 09:16:55 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:38:34 -0500
commitcc6fae19aec734aa71e93d92b2e1a8145170c811 (patch)
treef3c98da041bf9135e21d88234ccb47425e9cb91c /source4/pidl/Makefile.PL
parent3e4f47aaff41b5bb6d1d86025915a3a63dc1ea73 (diff)
downloadsamba-cc6fae19aec734aa71e93d92b2e1a8145170c811.tar.gz
samba-cc6fae19aec734aa71e93d92b2e1a8145170c811.tar.bz2
samba-cc6fae19aec734aa71e93d92b2e1a8145170c811.zip
r10380: Use pod-style documentation rather then XML-doc, in good perl style.
(This used to be commit fcc1ba97a3dd955208d8d9555ff8dab455239412)
Diffstat (limited to 'source4/pidl/Makefile.PL')
-rwxr-xr-xsource4/pidl/Makefile.PL14
1 files changed, 2 insertions, 12 deletions
diff --git a/source4/pidl/Makefile.PL b/source4/pidl/Makefile.PL
index fa250cabc3..f5cd3e4eff 100755
--- a/source4/pidl/Makefile.PL
+++ b/source4/pidl/Makefile.PL
@@ -3,23 +3,13 @@ WriteMakefile(
'NAME' => 'Parse::Pidl',
'VERSION_FROM' => 'lib/Parse/Pidl.pm',
'EXE_FILES' => [ 'pidl' ],
- 'PMLIBDIRS' => [ 'lib' ],
'test' => { 'TESTS' => 'tests/*.pl' }
);
sub MY::postamble {
<<'EOT';
-lib/Parse/Pidl/IDL.pm :: idl.yp
- yapp -s -m 'Parse::Pidl::IDL' -o 'lib/Parse/Pidl/IDL.pm' idl.yp
+lib/Parse/Pidl/IDL.pm: idl.yp
+ yapp -s -m 'Parse::Pidl::IDL' -o lib/Parse/Pidl/IDL.pm idl.yp
-doc: pidl.1 pidl.1.html
-
-XSLTPROC=xsltproc
-
-%.1: %.1.xml
- test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
-
-%.html: %.xml
- test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $<
EOT
}