summaryrefslogtreecommitdiff
path: root/docs/docbook/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'docs/docbook/configure.in')
-rw-r--r--docs/docbook/configure.in32
1 files changed, 31 insertions, 1 deletions
diff --git a/docs/docbook/configure.in b/docs/docbook/configure.in
index 25abecafe1..05747b0596 100644
--- a/docs/docbook/configure.in
+++ b/docs/docbook/configure.in
@@ -8,8 +8,33 @@ AC_PATH_PROG(PDFLATEX, pdflatex)
if test "x$PDFLATEX" = x; then
AC_MSG_ERROR("pdflatex is required")
fi
+AC_PATH_PROG(MAKEINDEX, makeindex)
+if test "x$MAKEINDEX" = x; then
+ AC_MSG_ERROR("makeindex is required")
+fi
+
+PAPERSIZE=""
+TEXSTYLESHEET=xslt/latex.xsl
+DUPLICATE_ULINKS=""
+
+CROP="--stringparam docrop 0"
+
+AC_ARG_ENABLE(crop,
+[ --enable-crop Whether to use a crop template],
+[ test "$withval" && CROP="--stringparam docrop 1" ])
+
+PAPERSIZE="--stringparam papersize a4paper"
+
+AC_ARG_WITH(papersize,
+[ --with-papersize Specify papersize (a4paper,letter) ],
+[ test "$withval" && PAPERSIZE="--stringparam papersize $withval" ])
+
+FONTSIZE="--stringparam fontsize 10.5"
+
+AC_ARG_WITH(fontsize,
+[ --with-fontsize Specify the fontsize in points (default: 10.5) ],
+[ test "$withval" && FONTSIZE="--stringparam fontsize $withval" ])
-AC_PATH_PROG(XMLTO, xmlto)
AC_PATH_PROG(LATEX, latex)
AC_PATH_PROG(DVIPS, dvips)
AC_PATH_PROG(PNGTOPNM, pngtopnm)
@@ -17,5 +42,10 @@ AC_PATH_PROG(PNMTOPS, pnmtops)
DOC_BUILD_DATE=`date '+%d-%m-%Y'`
AC_SUBST(DOC_BUILD_DATE)
+AC_SUBST(TEXSTYLESHEET)
+AC_SUBST(PAPERSIZE)
+AC_SUBST(DUPLICATE_ULINKS)
+AC_SUBST(FONTSIZE)
+AC_SUBST(CROP)
AC_OUTPUT( Makefile )