summaryrefslogtreecommitdiff
path: root/lib/dnspython/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'lib/dnspython/setup.py')
-rwxr-xr-xlib/dnspython/setup.py63
1 files changed, 63 insertions, 0 deletions
diff --git a/lib/dnspython/setup.py b/lib/dnspython/setup.py
new file mode 100755
index 0000000000..12fd2f1dc6
--- /dev/null
+++ b/lib/dnspython/setup.py
@@ -0,0 +1,63 @@
+#!/usr/bin/env python
+#
+# Copyright (C) 2003-2007, 2009, 2010 Nominum, Inc.
+#
+# Permission to use, copy, modify, and distribute this software and its
+# documentation for any purpose with or without fee is hereby granted,
+# provided that the above copyright notice and this permission notice
+# appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND NOMINUM DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL NOMINUM BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT
+# OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+import sys
+from distutils.core import setup
+
+version = '1.8.0'
+
+kwargs = {
+ 'name' : 'dnspython',
+ 'version' : version,
+ 'description' : 'DNS toolkit',
+ 'long_description' : \
+ """dnspython is a DNS toolkit for Python. It supports almost all
+record types. It can be used for queries, zone transfers, and dynamic
+updates. It supports TSIG authenticated messages and EDNS0.
+
+dnspython provides both high and low level access to DNS. The high
+level classes perform queries for data of a given name, type, and
+class, and return an answer set. The low level classes allow
+direct manipulation of DNS zones, messages, names, and records.""",
+ 'author' : 'Bob Halley',
+ 'author_email' : 'halley@dnspython.org',
+ 'license' : 'BSD-like',
+ 'url' : 'http://www.dnspython.org',
+ 'packages' : ['dns', 'dns.rdtypes', 'dns.rdtypes.IN', 'dns.rdtypes.ANY'],
+ }
+
+if sys.hexversion >= 0x02020300:
+ kwargs['download_url'] = \
+ 'http://www.dnspython.org/kits/%s/dnspython-%s.tar.gz' % (version,
+ version)
+ kwargs['classifiers'] = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Intended Audience :: System Administrators",
+ "License :: Freeware",
+ "Operating System :: Microsoft :: Windows :: Windows 95/98/2000",
+ "Operating System :: POSIX",
+ "Programming Language :: Python",
+ "Topic :: Internet :: Name Service (DNS)",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ]
+
+if sys.hexversion >= 0x02050000:
+ kwargs['requires'] = []
+ kwargs['provides'] = ['dns']
+
+setup(**kwargs)