summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian-sarge/scripts/unpatch-source
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian-sarge/scripts/unpatch-source')
-rw-r--r--packaging/Debian/debian-sarge/scripts/unpatch-source20
1 files changed, 20 insertions, 0 deletions
diff --git a/packaging/Debian/debian-sarge/scripts/unpatch-source b/packaging/Debian/debian-sarge/scripts/unpatch-source
new file mode 100644
index 0000000000..3ded1150ba
--- /dev/null
+++ b/packaging/Debian/debian-sarge/scripts/unpatch-source
@@ -0,0 +1,20 @@
+#!/bin/sh -e
+#
+#
+
+# We want to reverse the patches in the opposite order we applied
+# them, hence the 'ls|sort -r'.
+for patch in `ls debian/patches/*.patch | sort -r`; do
+ patch -p1 -R --ignore-whitespace < $patch
+done
+
+# Unused code. See comment in the patch-source script.
+
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && sh ./autogen.sh)
+
+exit 0