summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/patches/fhs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian/patches/fhs.patch')
-rw-r--r--packaging/Debian/debian/patches/fhs.patch19
1 files changed, 10 insertions, 9 deletions
diff --git a/packaging/Debian/debian/patches/fhs.patch b/packaging/Debian/debian/patches/fhs.patch
index c19c42006f..fa1f464f10 100644
--- a/packaging/Debian/debian/patches/fhs.patch
+++ b/packaging/Debian/debian/patches/fhs.patch
@@ -32,7 +32,7 @@ diff -uNr samba-3.0alpha23.orig/source/Makefile.in samba-3.0alpha23/source/Makef
PATH_FLAGS = $(PATH_FLAGS6) $(PASSWD_FLAGS)
# Note that all executable programs now provide for an optional executable suffix.
-@@ -1133,7 +1141,7 @@
+@@ -1128,7 +1136,7 @@
@$(SHELL) $(srcdir)/script/installscripts.sh $(INSTALLPERMS) $(DESTDIR)$(BINDIR) $(SCRIPTS)
installdat: installdirs
@@ -131,7 +131,7 @@ diff -uNr samba-3.0alpha23.orig/source/dynconfig.c samba-3.0alpha23/source/dynco
diff -uNr samba-3.0alpha23.orig/source/groupdb/mapping.c samba-3.0alpha23/source/groupdb/mapping.c
--- samba-3.0alpha23.orig/source/groupdb/mapping.c 2003-03-30 20:28:28.000000000 -0600
+++ samba-3.0alpha23/source/groupdb/mapping.c 2003-04-04 21:04:05.000000000 -0600
-@@ -134,7 +134,7 @@
+@@ -214,7 +214,7 @@
if (tdb && local_pid == sys_getpid())
return True;
@@ -310,11 +310,12 @@ diff -uNr samba-3.0alpha23.orig/source/nmbd/nmbd_serverlistdb.c samba-3.0alpha23
trim_string(fname,NULL,"/");
pstrcat(fname,"/");
pstrcat(fname,SERVER_LIST);
---- samba_3_0/source/nsswitch/winbindd_cache.c.orig 2003-06-18 11:08:35.000000000 -0400
-+++ samba_3_0/source/nsswitch/winbindd_cache.c 2003-06-18 11:10:04.000000000 -0400
-@@ -54,7 +54,7 @@
- if (opt_nocache)
- return;
+diff -uNr samba-3.0alpha23.orig/source/nsswitch/winbindd_cache.c samba-3.0alpha23/source/nsswitch/winbindd_cache.c
+--- samba-3.0alpha23.orig/source/nsswitch/winbindd_cache.c 2002-10-16 12:52:31.000000000 -0500
++++ samba-3.0alpha23/source/nsswitch/winbindd_cache.c 2003-04-04 21:04:06.000000000 -0600
+@@ -53,7 +53,7 @@
+ }
+ if (opt_nocache) return;
- wcache->tdb = tdb_open_log(lock_path("winbindd_cache.tdb"), 5000,
+ wcache->tdb = tdb_open_log(cache_path("winbindd_cache.tdb"), 5000,
@@ -334,7 +335,7 @@ diff -uNr samba-3.0alpha23.orig/source/param/loadparm.c samba-3.0alpha23/source/
char *szLockDir;
char *szPidDir;
char *szRootdir;
-@@ -1054,8 +1057,13 @@
+@@ -1051,8 +1054,13 @@
{"config file", P_STRING, P_GLOBAL, &Globals.szConfigFile, NULL, NULL, FLAG_HIDE},
{"preload", P_STRING, P_GLOBAL, &Globals.szAutoServices, NULL, NULL, FLAG_ADVANCED | FLAG_DEVELOPER},
{"auto services", P_STRING, P_GLOBAL, &Globals.szAutoServices, NULL, NULL, FLAG_ADVANCED | FLAG_DEVELOPER},
@@ -500,7 +501,7 @@ diff -uNr samba-3.0alpha23.orig/source/wrepld/process.c samba-3.0alpha23/source/
diff -uNr samba-3.0alpha23.orig/source/passdb/pdb_tdb.c samba-3.0alpha23/source/passdb/pdb_tdb.c
--- samba-3.0alpha23.orig/source/passdb/pdb_tdb.c 2003-03-30 20:28:29.000000000 -0600
+++ samba-3.0alpha23/source/passdb/pdb_tdb.c 2003-04-30 13:51:43.000000000 -0500
-@@ -956,10 +956,7 @@
+@@ -943,10 +943,7 @@
if (location) {
tdb_state->tdbsam_location = talloc_strdup(pdb_context->mem_ctx, location);
} else {