summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/scripts/patch-source
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian/scripts/patch-source')
-rwxr-xr-xpackaging/Debian/debian/scripts/patch-source18
1 files changed, 15 insertions, 3 deletions
diff --git a/packaging/Debian/debian/scripts/patch-source b/packaging/Debian/debian/scripts/patch-source
index aabcbf709c..a8559b4167 100755
--- a/packaging/Debian/debian/scripts/patch-source
+++ b/packaging/Debian/debian/scripts/patch-source
@@ -4,11 +4,23 @@
for patch in debian/patches/*.patch; do
echo '->'`basename $patch`:
- patch -p1 < $patch
+ patch -p1 --ignore-whitespace < $patch
done
-cat debian/changelog | perl -pi -e '($version) = <STDIN> =~/\((.*)\)/; \
- s/\".*\"/\"$version for Debian\"/' source/include/version.h
+# This code is currently not used because it creates a long version
+# number string. For now we're sticking to <upstream version>-Debian,
+# as in 3.0.0rc2-Debian. peloy@debian.org.-
+
+# ---- Begin unused code ----
+# Get Debian version number from 1st line of the Debian changelog
+#DEBIAN_VERSION=`sed -n -e '1s/^.*(\(.*\)).*$/\1/p' debian/changelog`
+
+# Insert Debian version number in source/VERSION, which will then be
+# used to create source/include/version.h.
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1\"Debian-${DEBIAN_VERSION}\"/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+# ---- End unused code ----
# Regenerate configure only if it is older than configure.in
[ source/configure -ot source/configure.in ] && (cd source && sh ./autogen.sh)