summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/scripts/unpatch-source
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian/scripts/unpatch-source')
-rwxr-xr-xpackaging/Debian/debian/scripts/unpatch-source8
1 files changed, 6 insertions, 2 deletions
diff --git a/packaging/Debian/debian/scripts/unpatch-source b/packaging/Debian/debian/scripts/unpatch-source
index 0f577d362f..d3681cfa50 100755
--- a/packaging/Debian/debian/scripts/unpatch-source
+++ b/packaging/Debian/debian/scripts/unpatch-source
@@ -5,10 +5,14 @@
# We want to reverse the patches in the opposite order we applied
# them, hence the 'ls|sort -r'.
for patch in `ls debian/patches/*.patch | sort -r`; do
- patch -p1 -R < $patch
+ patch -p1 -R --ignore-whitespace < $patch
done
-perl -pi -e's/-.* for Debian//' source/include/version.h
+# Unused code. See comment in the patch-source script.
+
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
# Regenerate configure only if it is older than configure.in
[ source/configure -ot source/configure.in ] && (cd source && autoheader && autoconf)