summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 16e9af4b47..3c5f74a67e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1989,6 +1989,20 @@ if test x"$with_ads_support" = x"yes"; then
if test x$FOUND_KRB5 = x"no"; then
#################################################
+# see if this box has the SuSE location for the heimdal kerberos implementation
+AC_MSG_CHECKING(for /usr/include/heimdal)
+if test -d /usr/include/heimdal; then
+ CFLAGS="$CFLAGS -I/usr/heimdal/include"
+ CPPFLAGS="$CPPFLAGS -I/usr/heimdal/include"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+fi
+
+
+if test x$FOUND_KRB5 = x"no"; then
+#################################################
# see if this box has the RedHat location for kerberos
AC_MSG_CHECKING(for /usr/kerberos)
if test -d /usr/kerberos; then