summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index fe16d939ee..8d8fcab03d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -273,9 +273,17 @@ done
AC_LIBREPLACE_CC_CHECKS
+m4_include(lib/talloc/libtalloc.m4)
+
+TALLOC_OBJS=""
+for obj in ${TALLOC_OBJ}; do
+ TALLOC_OBJS="${TALLOCOBJS} ${tallocdir}/${obj}"
+done
+AC_SUBST(TALLOC_OBJS)
+
SAMBA_CPPFLAGS="-Iinclude -I${srcdir-.}/include -I. -I${srcdir-.}"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/lib/replace"
-SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/lib/talloc"
+SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/lib/tdb/include"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/libaddns"
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/librpc"