summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4edd818e87..34be4fe761 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2109,7 +2109,9 @@ fi
if test "x$enable_external_libtalloc" = xno
then
m4_include(../lib/talloc/libtalloc.m4)
- LINK_LIBTALLOC=STATIC
+ if test x"$USESHARED" == x"no" ; then
+ LINK_LIBTALLOC=STATIC
+ fi
LIBTALLOCVERSION=`grep ^VERSION ${tallocdir}/wscript | sed -e "s/'//g" -e 's/.* //'`
SMB_LIBRARY(talloc, 2, ${LIBTALLOCVERSION})
LIBTALLOC_OBJ0=""